aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-12-20 14:25:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-12-20 14:25:05 +0000
commit2fcbf52f19fa863c0d62a507afecd14ed7add91f (patch)
tree2176075d22c7846213ceca4797c541394426c7ec /toolchain/gcc/common.mk
parente71b93670e8401fa13ecb75b1c095290bfc5612c (diff)
downloadmaster-187ad058-2fcbf52f19fa863c0d62a507afecd14ed7add91f.tar.gz
master-187ad058-2fcbf52f19fa863c0d62a507afecd14ed7add91f.tar.bz2
master-187ad058-2fcbf52f19fa863c0d62a507afecd14ed7add91f.zip
gcc: fix newer libstdc++ compile issues with uclibc 0.9.32
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24734 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index ebc5c1e6db..3a4a94a46a 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -95,6 +95,9 @@ SEP:=,
TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
export libgcc_cv_fixed_point=no
+ifdef CONFIG_USE_UCLIBC
+ export glibcxx_cv_c99_math_tr1=no
+endif
GCC_CONFIGURE:= \
SHELL="$(BASH)" \