aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2006-02-06 11:26:51 +0000
committerImre Kaloz <kaloz@openwrt.org>2006-02-06 11:26:51 +0000
commitb617bcc343aa9dd13541831e1db291fb66dab776 (patch)
tree381423c4c2a50ac4d90f73a6037884ff2a610b6b /toolchain/gcc/Makefile
parent2cc350b51a00a545b77980700ab5e512dc79a786 (diff)
downloadmaster-187ad058-b617bcc343aa9dd13541831e1db291fb66dab776.tar.gz
master-187ad058-b617bcc343aa9dd13541831e1db291fb66dab776.tar.bz2
master-187ad058-b617bcc343aa9dd13541831e1db291fb66dab776.zip
make gcc4 depend on libgcc, and disable the libgcc hack for it
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3161 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/Makefile')
-rw-r--r--toolchain/gcc/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 2d24cdd13e..26e17ad61e 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -193,11 +193,7 @@ endif
# We do another ugly hack here because the standard behaviour is
# to include a reference to libgcc.so.1 in all binaries. For flash space
# saving, we change the specs file to link in a static libgcc here.
- if [ ! -f $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ] ; then \
- echo staging dir specs file is missing, assuming GCC 4.x ; \
- $(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)-gcc -dumpspecs > $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs; \
- fi;
- if grep -q as-needed $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs; then \
+ if [ -f $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ] ; then \
patch -d $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/ -p0 < ./$(GCC_VERSION)/static-libgcc.patch.conditional ; \
fi;