aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/eglibc
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-07-07 09:42:47 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-07-07 09:42:47 +0000
commit5730f1c9a369976885e1ffe269543f806acf6e81 (patch)
tree0007e2996e70dc4a851d53af92f8c688cc589fc6 /toolchain/eglibc
parent736856c20800517dbbe5d49d498e56983d8e7905 (diff)
downloadmaster-187ad058-5730f1c9a369976885e1ffe269543f806acf6e81.tar.gz
master-187ad058-5730f1c9a369976885e1ffe269543f806acf6e81.tar.bz2
master-187ad058-5730f1c9a369976885e1ffe269543f806acf6e81.zip
[toolchain] eglibc: add support for 2.14
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27510 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/eglibc')
-rw-r--r--toolchain/eglibc/Config.in5
-rw-r--r--toolchain/eglibc/Config.version1
-rw-r--r--toolchain/eglibc/Makefile5
3 files changed, 10 insertions, 1 deletions
diff --git a/toolchain/eglibc/Config.in b/toolchain/eglibc/Config.in
index fb2b982b18..8d84f5af20 100644
--- a/toolchain/eglibc/Config.in
+++ b/toolchain/eglibc/Config.in
@@ -13,6 +13,10 @@ choice
bool "eglibc 2.13"
depends !GCC_VERSION_LLVM
+ config EGLIBC_VERSION_2_14
+ bool "eglibc 2.14"
+ depends !GCC_VERSION_LLVM
+
config EGLIBC_VERSION_TRUNK
bool "eglibc trunk"
@@ -24,6 +28,7 @@ config EGLIBC_REVISION
depends on TOOLCHAINOPTS && USE_EGLIBC
default "10495" if EGLIBC_VERSION_2_12
default "13055" if EGLIBC_VERSION_2_13
+ default "14284" if EGLIBC_VERSION_2_14
default "HEAD" if EGLIBC_VERSION_TRUNK
default ""
diff --git a/toolchain/eglibc/Config.version b/toolchain/eglibc/Config.version
index 3a81ded449..6b67cdda37 100644
--- a/toolchain/eglibc/Config.version
+++ b/toolchain/eglibc/Config.version
@@ -3,4 +3,5 @@ config EGLIBC_VERSION
depends on USE_EGLIBC
default "2.12" if EGLIBC_VERSION_2_12
default "2.13" if EGLIBC_VERSION_2_13
+ default "2.14" if EGLIBC_VERSION_2_14
default "trunk"
diff --git a/toolchain/eglibc/Makefile b/toolchain/eglibc/Makefile
index 985c34bbda..7d964bacfd 100644
--- a/toolchain/eglibc/Makefile
+++ b/toolchain/eglibc/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -21,6 +21,9 @@ endif
ifneq ($(CONFIG_EGLIBC_VERSION_2_13),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_13
endif
+ifneq ($(CONFIG_EGLIBC_VERSION_2_14),)
+ PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_14
+endif
ifneq ($(CONFIG_EGLIBC_VERSION_TRUNK),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/trunk
endif