aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/eglibc/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-11-22 12:27:39 +0000
committerNicolas Thill <nico@openwrt.org>2009-11-22 12:27:39 +0000
commit8e684d3bd22ac3e8b10e86372ccef1c599a9f873 (patch)
tree5783620f97a1ec4951f94cd0b267e2edd73f3f81 /toolchain/eglibc/Makefile
parente744727aa903615b8b751dc5b194b2e4396c3bf7 (diff)
downloadmaster-187ad058-8e684d3bd22ac3e8b10e86372ccef1c599a9f873.tar.gz
master-187ad058-8e684d3bd22ac3e8b10e86372ccef1c599a9f873.tar.bz2
master-187ad058-8e684d3bd22ac3e8b10e86372ccef1c599a9f873.zip
[toolchain] eglibc: don't use minor version numbers in config symbols, only in version strings
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18474 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/eglibc/Makefile')
-rw-r--r--toolchain/eglibc/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/toolchain/eglibc/Makefile b/toolchain/eglibc/Makefile
index 0363dd9061..b72b4bd356 100644
--- a/toolchain/eglibc/Makefile
+++ b/toolchain/eglibc/Makefile
@@ -15,22 +15,22 @@ PKG_SOURCE_VERSION:=$(PKG_REVISION)
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-r$(PKG_REVISION)
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
-ifeq ($(PKG_VERSION),2.6.1)
+ifneq ($(CONFIG_EGLIBC_VERSION_2_6),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_6
endif
-ifeq ($(PKG_VERSION),2.7)
+ifneq ($(CONFIG_EGLIBC_VERSION_2_7),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_7
endif
-ifeq ($(PKG_VERSION),2.8)
+ifneq ($(CONFIG_EGLIBC_VERSION_2_8),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_8
endif
-ifeq ($(PKG_VERSION),2.9)
+ifneq ($(CONFIG_EGLIBC_VERSION_2_9),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_9
endif
-ifeq ($(PKG_VERSION),2.10.1)
+ifneq ($(CONFIG_EGLIBC_VERSION_2_10),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_10
endif
-ifeq ($(PKG_VERSION),trunk)
+ifneq ($(CONFIG_EGLIBC_VERSION_TRUNK),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/trunk
endif