aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-06 10:18:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-06 10:18:50 +0000
commitc9df1f5908d5f3245e79146d27d24f65fecdf96f (patch)
tree4f5f9f6430f964cdfa1d0eebc53e4d336afd6e68 /target
parent33c550257c6f8c8d2482d63baa3503faa47f6a62 (diff)
downloadmaster-187ad058-c9df1f5908d5f3245e79146d27d24f65fecdf96f.tar.gz
master-187ad058-c9df1f5908d5f3245e79146d27d24f65fecdf96f.tar.bz2
master-187ad058-c9df1f5908d5f3245e79146d27d24f65fecdf96f.zip
ar71xx: fix UAP-PRO images
- it should be BOARDNAME instead of BOARD_NAME - kernel partition should be padded to 1536k (somehow this padding was lost in translation to BuildCode in bc797c73f6328941b2194d144385655ad9297e7c) Signed-off-by: Roman Yeryomin <roman@advem.lv> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46193 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 3956927ce4..3ca52dd4f1 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -852,18 +852,18 @@ define Device/ubnt-uap-pro
MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1536k(kernel),14208k(rootfs),256k(cfg)ro,64k(EEPROM)ro,15744k@0x50000(firmware)
UBNT_TYPE := BZ
UBNT_CHIP := ar934x
- BOARD_NAME := UAP-PRO
+ BOARDNAME := UAP-PRO
DEVICE_PROFILE := UBNT UAPPRO
KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma | mkubntkernelimage
IMAGES := sysupgrade.bin factory.bin
- IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | mkubntimage2
+ IMAGE/sysupgrade.bin = append-kernel 1536k | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin = $$(IMAGE/sysupgrade.bin) | mkubntimage2
endef
define Device/ubnt-unifi-outdoor-plus
$(Device/ubnt-uap-pro)
UBNT_CHIP := ar7240
- BOARD_NAME := UBNT-UOP
+ BOARDNAME := UBNT-UOP
DEVICE_PROFILE := UBNT
endef