aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2005-02-12 02:35:19 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2005-02-12 02:35:19 +0000
commitc8860eaa4b68ad359e79e3d117abc85a0a7607ab (patch)
treefad02c941186a7d17671f3170e3eb813078bf838 /target
parent727deb6fddede996685cd11a3cc1cbf4b1000662 (diff)
downloadmaster-187ad058-c8860eaa4b68ad359e79e3d117abc85a0a7607ab.tar.gz
master-187ad058-c8860eaa4b68ad359e79e3d117abc85a0a7607ab.tar.bz2
master-187ad058-c8860eaa4b68ad359e79e3d117abc85a0a7607ab.zip
some Makefile cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@230 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/squashfs/Makefile.in2
-rw-r--r--target/squashfs/squashfsroot.mk14
2 files changed, 14 insertions, 2 deletions
diff --git a/target/squashfs/Makefile.in b/target/squashfs/Makefile.in
index f78961776a..a5f875af84 100644
--- a/target/squashfs/Makefile.in
+++ b/target/squashfs/Makefile.in
@@ -1,3 +1,3 @@
ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS)),y)
-TARGETS+=squashfsroot openwrt-code.bin.squashfs
+TARGETS+=openwrt-image
endif
diff --git a/target/squashfs/squashfsroot.mk b/target/squashfs/squashfsroot.mk
index f3d2808592..f97b6419a5 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/target/squashfs/squashfsroot.mk
@@ -4,6 +4,8 @@
#
#############################################################
+ROOTFSTYPE=squashfs
+
SQUASHFS_DIR=$(BUILD_DIR)/squashfs2.1-r2
SQUASHFS_SOURCE=squashfs2.1-r2.tar.gz
SQUASHFS_SITE=http://dl.sourceforge.net/sourceforge/squashfs
@@ -38,7 +40,7 @@ squashfs-dirclean:
squashfsroot: squashfs
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/info
- $(SQUASHFS_DIR)/squashfs-tools/mksquashfs $(TARGET_DIR) $(IMAGE).squashfs -noappend -root-owned -le
+ $(SQUASHFS_DIR)/squashfs-tools/mksquashfs $(TARGET_DIR) $(IMAGE).$(ROOTFSTYPE) -noappend -root-owned -le
squashfsroot-source: squashfs-source
@@ -48,3 +50,13 @@ squashfsroot-clean:
squashfsroot-dirclean:
rm -rf $(SQUASHFS_DIR)
+openwrt-linux.trx.$(ROOTFSTYPE):
+ $(BUILD_DIR)/trx -o openwrt-linux.trx.$(ROOTFSTYPE) $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFSTYPE)
+
+openwrt-gs-code.bin.$(ROOTFSTYPE): openwrt-linux.trx.$(ROOTFSTYPE)
+ $(BUILD_DIR)/addpattern -2 -i openwrt-linux.trx.$(ROOTFSTYPE) -o openwrt-gs-code.bin.$(ROOTFSTYPE) -g
+
+openwrt-g-code.bin.$(ROOTFSTYPE): openwrt-gs-code.bin.$(ROOTFSTYPE)
+ sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin.$(ROOTFSTYPE) > openwrt-g-code.bin.$(ROOTFSTYPE)
+
+openwrt-image: openwrt-g-code.bin.$(ROOTFSTYPE)