aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-30 22:55:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-30 22:55:50 +0000
commit8da0cd2349b05282fc4530772ca6d2698614ced7 (patch)
tree0d69b92123de54e92ba6c2241f2115316a55b948 /target
parent322128e5c9b55af508053aa859193e91c9c4bc32 (diff)
downloadmaster-187ad058-8da0cd2349b05282fc4530772ca6d2698614ced7.tar.gz
master-187ad058-8da0cd2349b05282fc4530772ca6d2698614ced7.tar.bz2
master-187ad058-8da0cd2349b05282fc4530772ca6d2698614ced7.zip
ar71xx: use Image/BuildLoaderPatched for TPLINK-SAFELOADER images
Building the loader in Image/Build/TPLINK-SAFELOADER would break the image builder as no target compiler is available in that stage. Fixes #19580 Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45855 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index fc66908d64..580a640786 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1495,14 +1495,10 @@ define Image/Build/TPLINK-LZMA/initramfs
endef
-Image/Build/TPLINK-SAFELOADER/buildkernel=$(call PatchKernelLzma,$(2),$(3) $(4))
+Image/Build/TPLINK-SAFELOADER/loader = $(call Image/BuildLoaderPatched,$(1),elf,$(2) $(3))
define Image/Build/TPLINK-SAFELOADER
- -rm -rf $(KDIR)/lzma-loader
- $(LOADER_MAKE) LOADER=loader-$(2).elf\
- LZMA_TEXT_START=0x80a00000 LOADADDR=0x80060000 \
- LOADER_DATA="$(KDIR_TMP)/vmlinux-$(2).bin.lzma" BOARD="$(2)" \
- compile loader.elf
+ [ -e "$(KDIR)/loader-$(2).elf" ]
-$(STAGING_DIR_HOST)/bin/tplink-safeloader \
-B $(5) \