aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-01-07 14:14:41 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-01-07 14:14:41 +0000
commit703cf9ca91059c47427f8b56c88ae88ed5999ed1 (patch)
tree3123e4b6bbddbce5d6570a4baa02da174df87129 /target
parent130b30fbba55d2da7582986f7a5b90bbdfb9a66e (diff)
downloadmaster-187ad058-703cf9ca91059c47427f8b56c88ae88ed5999ed1.tar.gz
master-187ad058-703cf9ca91059c47427f8b56c88ae88ed5999ed1.tar.bz2
master-187ad058-703cf9ca91059c47427f8b56c88ae88ed5999ed1.zip
ar71xx: add missing Makefile entry to the 74HC153 GPIO patch
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35035 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/patches-3.6/450-gpio-nxp-74hc153-gpio-chip-driver.patch10
-rw-r--r--target/linux/ar71xx/patches-3.7/450-gpio-nxp-74hc153-gpio-chip-driver.patch10
2 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.6/450-gpio-nxp-74hc153-gpio-chip-driver.patch b/target/linux/ar71xx/patches-3.6/450-gpio-nxp-74hc153-gpio-chip-driver.patch
index 57512c9eea..93c2e31f79 100644
--- a/target/linux/ar71xx/patches-3.6/450-gpio-nxp-74hc153-gpio-chip-driver.patch
+++ b/target/linux/ar71xx/patches-3.6/450-gpio-nxp-74hc153-gpio-chip-driver.patch
@@ -13,3 +13,13 @@
+ provides a GPIO interface supporting input mode only.
+
endif
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -43,6 +43,7 @@ obj-$(CONFIG_GPIO_MSM_V1) += gpio-msm-v1
+ obj-$(CONFIG_GPIO_MSM_V2) += gpio-msm-v2.o
+ obj-$(CONFIG_GPIO_MXC) += gpio-mxc.o
+ obj-$(CONFIG_GPIO_MXS) += gpio-mxs.o
++obj-$(CONFIG_GPIO_NXP_74HC153) += gpio-nxp-74hc153.o
+ obj-$(CONFIG_ARCH_OMAP) += gpio-omap.o
+ obj-$(CONFIG_GPIO_PCA953X) += gpio-pca953x.o
+ obj-$(CONFIG_GPIO_PCF857X) += gpio-pcf857x.o
diff --git a/target/linux/ar71xx/patches-3.7/450-gpio-nxp-74hc153-gpio-chip-driver.patch b/target/linux/ar71xx/patches-3.7/450-gpio-nxp-74hc153-gpio-chip-driver.patch
index 6f83350583..cdeb5f28ee 100644
--- a/target/linux/ar71xx/patches-3.7/450-gpio-nxp-74hc153-gpio-chip-driver.patch
+++ b/target/linux/ar71xx/patches-3.7/450-gpio-nxp-74hc153-gpio-chip-driver.patch
@@ -13,3 +13,13 @@
+ provides a GPIO interface supporting input mode only.
+
endif
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -45,6 +45,7 @@ obj-$(CONFIG_GPIO_MSM_V2) += gpio-msm-v2
+ obj-$(CONFIG_GPIO_MVEBU) += gpio-mvebu.o
+ obj-$(CONFIG_GPIO_MXC) += gpio-mxc.o
+ obj-$(CONFIG_GPIO_MXS) += gpio-mxs.o
++obj-$(CONFIG_GPIO_NXP_74HC153) += gpio-nxp-74hc153.o
+ obj-$(CONFIG_ARCH_OMAP) += gpio-omap.o
+ obj-$(CONFIG_GPIO_PCA953X) += gpio-pca953x.o
+ obj-$(CONFIG_GPIO_PCF857X) += gpio-pcf857x.o