aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDaniel Dickinson <daniel@cshore.neomailbox.net>2011-05-13 06:06:42 +0000
committerDaniel Dickinson <daniel@cshore.neomailbox.net>2011-05-13 06:06:42 +0000
commit6c5f918ef1e7bdad21dee9d50532c977fe429ecc (patch)
tree2e2678165992e8e3c596659711ac38b38a5851d0 /target
parent0da640db3ba718f600cbfd7cb9086c6f415fbbb7 (diff)
downloadmaster-187ad058-6c5f918ef1e7bdad21dee9d50532c977fe429ecc.tar.gz
master-187ad058-6c5f918ef1e7bdad21dee9d50532c977fe429ecc.tar.bz2
master-187ad058-6c5f918ef1e7bdad21dee9d50532c977fe429ecc.zip
This patch provides an image suitable for the alix2*, alix3, and alix6 headless (non-VGA equipped) SBC's.
Note that the Alix6 uses GPIO 27 to disable wireless transmit (W_DIS#), whereas on all other versions this is used to actuate the speaker. GPIO 1 : SIM select (Alix6) GPIO 6 : LED1 GPIO 25 : LED2 GPIO 27 : LED3 or RFKILL (Alix6) GPIO 24 : Soft switch 1 No kernel version bump. Added i2c-scx200-acb for lm-sensors support. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26879 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86/Makefile2
-rw-r--r--target/linux/x86/generic/profiles/Alix.mk16
-rw-r--r--target/linux/x86/image/Config.in1
3 files changed, 2 insertions, 17 deletions
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index e0a216d1b1..829d422377 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -10,7 +10,7 @@ ARCH:=i386
BOARD:=x86
BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext4 vdi vmdk pcmcia targz
-SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2
LINUX_VERSION:=2.6.37.6
diff --git a/target/linux/x86/generic/profiles/Alix.mk b/target/linux/x86/generic/profiles/Alix.mk
index c7d9f3253d..e69de29bb2 100644
--- a/target/linux/x86/generic/profiles/Alix.mk
+++ b/target/linux/x86/generic/profiles/Alix.mk
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Alix
- NAME:=PCEngines Alix
- PACKAGES:=kmod-via-rhine kmod-leds-alix
-endef
-
-define Profile/Alix/Description
- Package set compatible with the PCEngines Alix. Contains VIA Rhine III VT6105M and LED support
-endef
-$(eval $(call Profile,Alix))
diff --git a/target/linux/x86/image/Config.in b/target/linux/x86/image/Config.in
index 19f0cb342d..4847dd4ae5 100644
--- a/target/linux/x86/image/Config.in
+++ b/target/linux/x86/image/Config.in
@@ -21,6 +21,7 @@ config X86_GRUB_BAUDRATE
int "Serial port baud rate"
depends X86_GRUB_IMAGES
default 19200 if TARGET_x86_generic_Soekris45xx || TARGET_x86_generic_Soekris48xx || TARGET_x86_net5501
+ default 38400 if TARGET_x86_alix2
default 115200 if TARGET_x86_geos
default 38400