aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-02-05 11:25:21 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-02-05 11:25:21 +0000
commit6c1456ba13be7a2f638908c9b1a034c43c65abc2 (patch)
tree12d1aa8ebe25cb80727a7807af7b00488f71f56a /target
parentfc9eed55398f72066422db9a9c797e4da484dfe6 (diff)
downloadmaster-187ad058-6c1456ba13be7a2f638908c9b1a034c43c65abc2.tar.gz
master-187ad058-6c1456ba13be7a2f638908c9b1a034c43c65abc2.tar.bz2
master-187ad058-6c1456ba13be7a2f638908c9b1a034c43c65abc2.zip
mvebu: add a subprofile for boards based on a small NOR
Some boards only come with a small NOR on it, where UBI isn't a good solution because of its overhead. Add a new subprofile for such boards, that rely on the mtd split framework instead. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44263 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/mvebu/image/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 7076e876e0..a8fc4de134 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -77,6 +77,31 @@ define UBINORProfile
endef
# $(1): Profile Name
+# $(2): DTB Name
+# $(3): Erase Block Size
+define NORProfile
+ define Image/BuildKernel/Profile/$(1)
+ $(call Image/Build/DTB,$(2))
+ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(call Image/Build/Profile,$(1)/Initramfs)
+ endif
+ endef
+
+ define Image/Build/Profile/$(1)/Initramfs
+ $(call Image/Build/DTB,$(2),-initramfs)
+ endef
+
+ define Image/Build/Profile/$(1)/squashfs
+ ( \
+ dd if=$(KDIR)/uImage-$(2) bs=$(3) conv=sync; \
+ dd if=$(KDIR)/root.squashfs bs=$(3) conv=sync; \
+ ) > $$(BIN_DIR)/$$(IMG_PREFIX)-$(2)-squashfs-firmware.bin
+ endef
+
+ PROFILES_LIST += $(1)
+endef
+
+# $(1): Profile Name
# $(2): Sub Profiles list
define MultiProfile
define Image/BuildKernel/Profile/$(1)