aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-11-18 22:23:42 +0000
committerLuka Perkov <luka@openwrt.org>2013-11-18 22:23:42 +0000
commit60c8260052dc7d39d33c303322f12c6c24bca0dc (patch)
tree396dcd7c3aca1b093d2714530e9c9c4a20cbf7f7 /target
parent5fc33c5d887f7ae9bdf24f33e937fa14365b18da (diff)
downloadmaster-187ad058-60c8260052dc7d39d33c303322f12c6c24bca0dc.tar.gz
master-187ad058-60c8260052dc7d39d33c303322f12c6c24bca0dc.tar.bz2
master-187ad058-60c8260052dc7d39d33c303322f12c6c24bca0dc.zip
imx6: merge all gateworks boards into one profile
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38858 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/imx6/image/Makefile31
-rw-r--r--target/linux/imx6/profiles/120-gateworks.mk51
2 files changed, 32 insertions, 50 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 6cdb6c9fba..1c68cb0e40 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -12,6 +12,7 @@ $(shell echo $(PROFILE) | tr '[:upper:]' '[:lower:]' | sed 's/_/-/g')
endef
define Image/BuildKernel/Template
+
$(CP) $(LINUX_DIR)/arch/arm/boot/dts/$(1).dtb $(BIN_DIR)/$(IMG_PREFIX)-$(1).dtb
$(call Image/BuildKernel/MkFIT,$(1),$(KDIR)/zImage,$(BIN_DIR)/$(IMG_PREFIX)-$(1).dtb,none,0x10008000,0x10008000)
@@ -52,17 +53,18 @@ define Image/InstallKernel/Template
ln -sf $(IMG_PREFIX)-zImage $(TARGET_DIR)/boot/zImage
endif
ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_FIT),)
- $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-fit-uImage.itb $(TARGET_DIR)/boot/
- ln -sf $(IMG_PREFIX)-$(1)-fit-uImage.itb $(TARGET_DIR)/boot/uImage.itb
+ $(foreach dts,$(shell echo $(1)), \
+ $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(dts)-fit-uImage.itb $(TARGET_DIR)/boot/
+ )
endif
endif
ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
$(INSTALL_DIR) $(TARGET_DIR)/boot
- ifneq ($(1),)
- $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(1).dtb $(TARGET_DIR)/boot/
- ln -sf $(IMG_PREFIX)-$(1).dtb $(TARGET_DIR)/boot/$(1).dtb
- endif
+ $(foreach dts,$(shell echo $(1)), \
+ $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb $(TARGET_DIR)/boot/ ; \
+ ln -sf $(IMG_PREFIX)-$(dts).dtb $(TARGET_DIR)/boot/$(dts).dtb ; \
+ )
endif
endef
@@ -82,15 +84,15 @@ endef
define ubifs_imx_gateworks_ventana
# Micron MT29F1G08ABAD/MT29F2G08ABAE/MT29F4G08ABAD/MT29F8G08ADAD NAND
- $(eval IMX6Q_GW54XX_UBIFS_OPTS:="-m 2048 -e 124KiB -c 8124")
- $(eval IMX6Q_GW54XX_UBI_OPTS:="-m 2048 -p 128KiB -s 2048")
+ $(eval VENTANA_UBIFS_OPTS:="-m 2048 -e 124KiB -c 8124")
+ $(eval VENTANA_UBI_OPTS:="-m 2048 -p 128KiB -s 2048")
$(call Image/mkfs/ubifs)
$(CP) $(KDIR)/root.ubifs $(BIN_DIR)/$(IMG_PREFIX)-$(call sanitize_profile_name)-rootfs_normal.ubifs
$(CP) $(KDIR)/root.ubi $(BIN_DIR)/$(IMG_PREFIX)-$(call sanitize_profile_name)-rootfs_normal.ubi
# Micron MT29F8G08ABAC/MT29F16G08ADAC 1GB/2GB NAND
- $(eval IMX6Q_GW54XX_UBIFS_OPTS:="-m 4096 -e 248KiB -c 8124")
- $(eval IMX6Q_GW54XX_UBI_OPTS:="-m 4096 -p 256KiB -s 4096")
+ $(eval VENTANA_UBIFS_OPTS:="-m 4096 -e 248KiB -c 8124")
+ $(eval VENTANA_UBI_OPTS:="-m 4096 -p 256KiB -s 4096")
$(call Image/mkfs/ubifs)
$(CP) $(KDIR)/root.ubifs $(BIN_DIR)/$(IMG_PREFIX)-$(call sanitize_profile_name)-rootfs_large.ubifs
$(CP) $(KDIR)/root.ubi $(BIN_DIR)/$(IMG_PREFIX)-$(call sanitize_profile_name)-rootfs_large.ubi
@@ -111,12 +113,9 @@ Image/InstallKernel/Template/generic=$(call Image/InstallKernel/Template)
Image/BuildKernel/Template/IMX6DL_WANDBOARD=$(call Image/BuildKernel/Template,imx6dl-wandboard)
Image/InstallKernel/Template/IMX6DL_WANDBOARD=$(call Image/InstallKernel/Template,imx6dl-wandboard)
-Image/BuildKernel/Template/IMX6Q_GW5400_A=$(call Image/BuildKernel/Template,imx6q-gw5400-a)
-Image/InstallKernel/Template/IMX6Q_GW5400_A=$(call Image/InstallKernel/Template,imx6q-gw5400-a)
-
-Image/BuildKernel/Template/IMX6Q_GW54XX=$(call Image/BuildKernel/Template,imx6q-gw54xx)
-Image/InstallKernel/Template/IMX6Q_GW54XX=$(call Image/InstallKernel/Template,imx6q-gw54xx)
-Image/ubifs/IMX6Q_GW54XX=$(call ubifs_imx_gateworks_ventana)
+Image/BuildKernel/Template/VENTANA=$(foreach dts,$(shell echo $(VENTANA_DTS)),$(call Image/BuildKernel/Template,$(dts)))
+Image/InstallKernel/Template/VENTANA=$(call Image/InstallKernel/Template,$(VENTANA_DTS))
+Image/ubifs/VENTANA=$(call ubifs_imx_gateworks_ventana)
define Image/BuildKernel
diff --git a/target/linux/imx6/profiles/120-gateworks.mk b/target/linux/imx6/profiles/120-gateworks.mk
index a62fd1e81a..16d59b43d6 100644
--- a/target/linux/imx6/profiles/120-gateworks.mk
+++ b/target/linux/imx6/profiles/120-gateworks.mk
@@ -5,53 +5,36 @@
# See /LICENSE for more information.
#
-define Profile/IMX6Q_GW5400_A
- NAME:=Gateworks Ventana GW5400-A
- PACKAGES:= \
- kmod-thermal-imx kmod-sky2 kmod-usb-chipidea kmod-usb-mxs-phy \
- kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000
-endef
-
-define Profile/IMX6Q_GW5400_A/Description
- The Gateworks GW5400-A family of products is based on the Freescale i.MX6Q SoC
- and offers a large variety of peripherals such as:
-
- * DDR3
- * SPI FLASH
- * 6x PCIe (3x with USB)
- * Optional expansion for additional USB/PCI based periperhals
- * 1x USB EHCI
- * 1x USB OTG
- * HDMI Audio/Video in/out
- * Analog Video in/out
- * Analog Audio in/out
- * Gateworks System Controller
-endef
-
-$(eval $(call Profile,IMX6Q_GW5400_A))
-
-define Profile/IMX6Q_GW54XX
- NAME:=Gateworks Ventana i.MX6 Quad GW54XX
+define Profile/VENTANA
+ NAME:=Gateworks Ventana family
PACKAGES:= \
kmod-thermal-imx kmod-sky2 kmod-usb-chipidea kmod-usb-mxs-phy \
kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
kobs-ng
endef
-define Profile/IMX6Q_GW54XX/Description
- The Gateworks GW54xx family of products is based on the Freescale i.MX6Q SoC
+define Profile/VENTANA/Description
+ The Gateworks Ventana family of products is based on the Freescale i.MX6Q SoC
and offers a large variety of peripherals such as:
* DDR3
- * NAND FLASH
- * 6x PCIe (3x with USB)
+ * NAND or SPI flash
+ * multiple PCIe (with USB for Cellular modems)
* Optional expansion for additional USB/PCI based periperhals
- * 1x USB EHCI
- * 1x USB OTG
+ * USB EHCI
+ * USB OTG
* HDMI Audio/Video in/out
* Analog Video in/out
* Analog Audio in/out
* Gateworks System Controller
+ * Optional GPS with PPS
+ * Canbus
+ * User GPIO
+ * mSATA
endef
-$(eval $(call Profile,IMX6Q_GW54XX))
+VENTANA_DTS:= \
+ imx6q-gw5400-a \
+ imx6q-gw54xx
+
+$(eval $(call Profile,VENTANA))