aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-09 18:17:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-09 18:17:52 +0000
commit5081feb90fcc5070f0d2585103eacf397db4424c (patch)
tree5093a241b0cce2442ae060e275b3882a42cf9a23 /target
parenta43b51a5c603e8a09ebdf9b48373c492b38b7e69 (diff)
downloadmaster-187ad058-5081feb90fcc5070f0d2585103eacf397db4424c.tar.gz
master-187ad058-5081feb90fcc5070f0d2585103eacf397db4424c.tar.bz2
master-187ad058-5081feb90fcc5070f0d2585103eacf397db4424c.zip
fix ar7 image alignment for jffs2
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4998 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/image/ar7/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/target/image/ar7/Makefile b/target/image/ar7/Makefile
index f56ceffb67..d2af2d9a81 100644
--- a/target/image/ar7/Makefile
+++ b/target/image/ar7/Makefile
@@ -66,12 +66,13 @@ define Image/Prepare
$(STAGING_DIR)/bin/srec2bin $(KDIR)/ram_zimage.sre $(KDIR)/vmlinux.bin
endef
-ifeq ($(FS),jffs2-8MB)
-ALIGN:=bs=131072 conv=sync
-endif
-ifeq ($(FS),jffs2-4MB)
-ALIGN:=bs=65536 conv=sync
-endif
+define align/jffs2-64k
+bs=65536 conv=sync
+endef
+
+define align/jffs2-128k
+bs=131072 conv=sync
+endef
define Image/Build/CyberTAN
(dd if=/dev/zero bs=16 count=1; cat $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin) | \
@@ -86,7 +87,7 @@ define Image/Build/sErCoMm
endef
define Image/Build
- dd if=$(KDIR)/vmlinux.bin $(ALIGN) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
+ dd if=$(KDIR)/vmlinux.bin $(call align/$(1)) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
cat $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
$(call Image/Build/CyberTAN,$(1),AG1B,AG1B,$(1))
$(call Image/Build/CyberTAN,$(1),WA21,WA21,$(1))