aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-01-30 08:23:36 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-01-30 08:23:36 +0000
commit42ecd8397208dbe45adcd4fb314ea1786ec55747 (patch)
tree1fd032bf1ab83cc7db08cd8dbad25c91757f6f88 /target
parentc142433b4ff385176eb822f850b420ee22f865b6 (diff)
downloadmaster-187ad058-42ecd8397208dbe45adcd4fb314ea1786ec55747.tar.gz
master-187ad058-42ecd8397208dbe45adcd4fb314ea1786ec55747.tar.bz2
master-187ad058-42ecd8397208dbe45adcd4fb314ea1786ec55747.zip
[adm5120] lzma-loader: fix compiler warnings
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10321 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/adm5120/image/lzma-loader/src/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/adm5120/image/lzma-loader/src/Makefile b/target/linux/adm5120/image/lzma-loader/src/Makefile
index aad845ae07..f23d040cdb 100644
--- a/target/linux/adm5120/image/lzma-loader/src/Makefile
+++ b/target/linux/adm5120/image/lzma-loader/src/Makefile
@@ -37,8 +37,8 @@ BIN_FLAGS := -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic \
- -ffunction-sections -pipe -mlong-calls -fno-common \
- -ffreestanding \
+ -ffunction-sections -pipe -mlong-calls -fno-common -ffreestanding \
+ -fhonour-copts \
-mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
CFLAGS += -DLOADADDR=$(LOADADDR) -D_LZMA_PROB32