aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-09-04 14:44:48 +0000
committerJonas Gorski <jogo@openwrt.org>2015-09-04 14:44:48 +0000
commit3c71b3315597b0c78742e2db4f48c1f72b2582f9 (patch)
tree9bd3e5f09365601ce47ef0c70eeab06ec91a1ca9 /target
parent72cb5455f0bfd564e84bde202a164d0d5b01eedd (diff)
downloadmaster-187ad058-3c71b3315597b0c78742e2db4f48c1f72b2582f9.tar.gz
master-187ad058-3c71b3315597b0c78742e2db4f48c1f72b2582f9.tar.bz2
master-187ad058-3c71b3315597b0c78742e2db4f48c1f72b2582f9.zip
ipq806x: wrap legacy image in uImage
Wrap the zImage in a uImage header so we can easily boot it from legacy u-boots. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46787 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ipq806x/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index b64d629be3..2369762ad8 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -38,8 +38,8 @@ endef
DEVICE_VARS += DEVICE_DTS
define Device/LegacyImage
- KERNEL_SUFFIX := -zImage
- KERNEL = kernel-bin | append-dtb
+ KERNEL_SUFFIX := -uImage
+ KERNEL = kernel-bin | append-dtb | uImage none
KERNEL_NAME := zImage
KERNEL_INSTALL := 1
endef