aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-05 10:27:34 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-05 10:27:34 +0000
commit328b39121448f658df2bf1652a8245c5e4be3ec9 (patch)
treef9107be224b99b45bf9c6964a39801c58a0cf240 /target
parent3700fab7c36c231d2e7764f05d8eb3369d10a8ba (diff)
downloadmaster-187ad058-328b39121448f658df2bf1652a8245c5e4be3ec9.tar.gz
master-187ad058-328b39121448f658df2bf1652a8245c5e4be3ec9.tar.bz2
master-187ad058-328b39121448f658df2bf1652a8245c5e4be3ec9.zip
brcm2708: switch device tree compilation to linux
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47124 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm2708/Makefile2
-rw-r--r--target/linux/brcm2708/image/Makefile8
2 files changed, 3 insertions, 7 deletions
diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
index 6d8aba018a..f8c93474c5 100644
--- a/target/linux/brcm2708/Makefile
+++ b/target/linux/brcm2708/Makefile
@@ -26,6 +26,6 @@ define Target/Description
Currently produces SD Card image for Raspberry Pi.
endef
-KERNELNAME:=Image
+KERNELNAME:=Image dtbs
$(eval $(call BuildTarget))
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index de222f0801..7a68c506cf 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -22,10 +22,6 @@ else
endif
### Image scripts ###
-define Build/build-dtb
- $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
-endef
-
define Build/gen-cfg
cat config.txt > $@.config
echo -e "\ndevice_tree=$(DEVICE_DTS).dtb" >> $@.config
@@ -44,7 +40,7 @@ define Build/boot-img
mcopy -i $@.boot cmdline.txt ::
mcopy -i $@.boot $@.config ::config.txt
mcopy -i $@.boot $(word 1,$^) ::kernel.img
- mcopy -i $@.boot $@.dtb ::$(DEVICE_DTS).dtb
+ mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
endef
define Build/sdcard-img
@@ -59,7 +55,7 @@ define Device/Default
PROFILES = Default $$(DEVICE_PROFILE)
KERNEL := kernel-bin
IMAGES := sdcard.bin
- IMAGE/sdcard.bin := build-dtb | gen-cfg | boot-img | sdcard-img
+ IMAGE/sdcard.bin := gen-cfg | boot-img | sdcard-img
DEVICE_PROFILE :=
DEVICE_DTS :=
endef