aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-11-11 13:40:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-11-11 13:40:51 +0000
commit30d7289d5b7600bfa5d4ad166e7ccef53b148f48 (patch)
tree4eae280218300a01340935895bddcf98c4fd004c /target
parent59317954fb819ddbd6d66354d18da48bb689ba69 (diff)
downloadmaster-187ad058-30d7289d5b7600bfa5d4ad166e7ccef53b148f48.tar.gz
master-187ad058-30d7289d5b7600bfa5d4ad166e7ccef53b148f48.tar.bz2
master-187ad058-30d7289d5b7600bfa5d4ad166e7ccef53b148f48.zip
extend mkdep fix (fixes #36)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2414 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch b/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch
index c1e18a0443..a43d1d2fe4 100644
--- a/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch
+++ b/target/linux/linux-2.4/patches/generic/209-mkdep_fix.patch
@@ -9,3 +9,14 @@
ifdef ALL_SUB_DIRS
$(MAKE) $(patsubst %,_sfdep_%,$(ALL_SUB_DIRS)) _FASTDEP_ALL_SUB_DIRS="$(ALL_SUB_DIRS)"
endif
+--- linux-2.4.30/Makefile.old 2005-11-11 14:27:55.878482250 +0100
++++ linux-2.4.30/Makefile 2005-11-11 14:28:57.926360000 +0100
+@@ -509,7 +509,7 @@
+ ifdef CONFIG_MODVERSIONS
+ $(MAKE) update-modverfile
+ endif
+- scripts/mkdep -- `find $(FINDHPATH) \( -name SCCS -o -name .svn \) -prune -o -follow -name \*.h ! -name modversions.h -print` > .hdepend
++ find $(FINDHPATH) \( -name SCCS -o -name .svn \) -prune -o -follow -name \*.h ! -name modversions.h -print | xargs scripts/mkdep -- > .hdepend
+ scripts/mkdep -- init/*.c > .depend
+
+ ifdef CONFIG_MODVERSIONS