aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-10-13 19:41:36 +0000
committerJohn Crispin <blogic@openwrt.org>2014-10-13 19:41:36 +0000
commitab41ed7d558bbbe2f91b2c6ba248d4895032136e (patch)
tree0935f1c1a564d3f38309a738dbb87421e91eedf5 /target/linux
parent0834da1573984aacde45d6dca9b87832fe1a8ae1 (diff)
downloadmaster-187ad058-ab41ed7d558bbbe2f91b2c6ba248d4895032136e.tar.gz
master-187ad058-ab41ed7d558bbbe2f91b2c6ba248d4895032136e.tar.bz2
master-187ad058-ab41ed7d558bbbe2f91b2c6ba248d4895032136e.zip
ralink: Build 8M image for 7Links PX-4885
7Links PX-4885 (clones) can also be purchased with 8MB flash. Creating images for these routers, use dtsi for common part Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42892 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/dts/PX4885-4M.dts42
-rw-r--r--target/linux/ramips/dts/PX4885-8M.dts42
-rw-r--r--target/linux/ramips/dts/PX4885.dtsi (renamed from target/linux/ramips/dts/PX4885.dts)39
-rw-r--r--target/linux/ramips/image/Makefile2
4 files changed, 85 insertions, 40 deletions
diff --git a/target/linux/ramips/dts/PX4885-4M.dts b/target/linux/ramips/dts/PX4885-4M.dts
new file mode 100644
index 0000000000..39bca1c760
--- /dev/null
+++ b/target/linux/ramips/dts/PX4885-4M.dts
@@ -0,0 +1,42 @@
+/dts-v1/;
+
+/include/ "PX4885.dtsi"
+
+/ {
+ palmbus@10000000 {
+ spi@b00 {
+ status = "okay";
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "mx25l3205d";
+ reg = <0 0>;
+ linux,modalias = "m25p80", "mx25l3205d";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x20000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "devdata";
+ reg = <0x20000 0x20000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "devconf";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x3b0000>;
+ };
+ };
+ };
+ };
+};
diff --git a/target/linux/ramips/dts/PX4885-8M.dts b/target/linux/ramips/dts/PX4885-8M.dts
new file mode 100644
index 0000000000..03cb5809ac
--- /dev/null
+++ b/target/linux/ramips/dts/PX4885-8M.dts
@@ -0,0 +1,42 @@
+/dts-v1/;
+
+/include/ "PX4885.dtsi"
+
+/ {
+ palmbus@10000000 {
+ spi@b00 {
+ status = "okay";
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "mx25l3205d";
+ reg = <0 0>;
+ linux,modalias = "m25p80", "mx25l3205d";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x20000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "devdata";
+ reg = <0x20000 0x20000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "devconf";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+ };
+ };
+ };
+};
diff --git a/target/linux/ramips/dts/PX4885.dts b/target/linux/ramips/dts/PX4885.dtsi
index 2bea444f82..1f47a17bbd 100644
--- a/target/linux/ramips/dts/PX4885.dts
+++ b/target/linux/ramips/dts/PX4885.dtsi
@@ -1,48 +1,9 @@
-/dts-v1/;
-
/include/ "rt5350.dtsi"
/ {
compatible = "PX4885", "ralink,rt5350-soc";
model = "7Links PX-4885";
- palmbus@10000000 {
- spi@b00 {
- status = "okay";
- m25p80@0 {
- #address-cells = <1>;
- #size-cells = <1>;
- compatible = "mx25l3205d";
- reg = <0 0>;
- linux,modalias = "m25p80", "mx25l3205d";
- spi-max-frequency = <10000000>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x0 0x20000>;
- read-only;
- };
-
- partition@20000 {
- label = "devdata";
- reg = <0x20000 0x20000>;
- read-only;
- };
-
- factory: partition@40000 {
- label = "devconf";
- reg = <0x40000 0x10000>;
- read-only;
- };
-
- partition@50000 {
- label = "firmware";
- reg = <0x50000 0x3b0000>;
- };
- };
- };
- };
-
pinctrl {
state_default: pinctrl0 {
gpio {
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 93554489a6..f048cafadc 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -466,7 +466,7 @@ Image/Build/Profile/PSR-680W=$(call BuildFirmware/Default4M/$(1),$(1),psr-680w,P
Image/Build/Profile/PWH2004=$(call BuildFirmware/Default8M/$(1),$(1),pwh2004,PWH2004)
-Image/Build/Profile/PX4885=$(call BuildFirmware/Default4M/$(1),$(1),px4885,PX4885)
+Image/Build/Profile/PX4885=$(call BuildFirmware/DefaultDualSize/$(1),$(1),px4885,PX4885)
Image/Build/Profile/RTG32B1=$(call BuildFirmware/Default4M/$(1),$(1),rt-g32-b1,RT-G32-B1)