aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-11-02 10:17:15 +0000
committerJohn Crispin <blogic@openwrt.org>2015-11-02 10:17:15 +0000
commit688b641c66325f4e319b6fa58134a5827ffaac11 (patch)
tree8bae6f63d13b3d42e6a448747cb6124ad2fb1727 /target/linux
parent86b60addb360f07a7e241e455af2ec85bcc0afe6 (diff)
downloadmaster-187ad058-688b641c66325f4e319b6fa58134a5827ffaac11.tar.gz
master-187ad058-688b641c66325f4e319b6fa58134a5827ffaac11.tar.bz2
master-187ad058-688b641c66325f4e319b6fa58134a5827ffaac11.zip
ar71xx: Add support for wdr7500v3
The device is similar to Archer C7 v2, but with 8M of flash, and 6 external antennas. Reason for breaking the naming pattern is that sticker on the back mentions "WDR7500" and has no mention of "Archer". Signed-off-by: Srdjan Rosic <rosic@google.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47344 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index ddc0fc1b15..7bf2f278eb 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -372,7 +372,14 @@ define Device/archer-c7-v2
DEVICE_PROFILE := ARCHERC7
TPLINK_HWID := 0xc7000002
endef
-TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2
+
+define Device/tl-wdr7500-v3
+ $(Device/tplink-8mlzma)
+ BOARDNAME := ARCHER-C7
+ DEVICE_PROFILE := ARCHERC7
+ TPLINK_HWID := 0x75000003
+endef
+TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2 tl-wdr7500-v3
define Device/antminer-s1
$(Device/tplink-8mlzma)