aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-07-19 14:51:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-07-19 14:51:56 +0000
commit4b6b1e38d282cc0053a21171b5583b28458f3875 (patch)
treeb195e82edad406c1eacc2b21fecf43f2d3b4c613 /target/linux
parentf5f5c87b75ccad659d80f69b60c8bae035cb4a5f (diff)
downloadmaster-187ad058-4b6b1e38d282cc0053a21171b5583b28458f3875.tar.gz
master-187ad058-4b6b1e38d282cc0053a21171b5583b28458f3875.tar.bz2
master-187ad058-4b6b1e38d282cc0053a21171b5583b28458f3875.zip
Really add the LED driver :)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8056 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/rb532-2.6/patches/510-rb500_led.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/rb532-2.6/patches/510-rb500_led.patch b/target/linux/rb532-2.6/patches/510-rb500_led.patch
new file mode 100644
index 0000000000..172682d49c
--- /dev/null
+++ b/target/linux/rb532-2.6/patches/510-rb500_led.patch
@@ -0,0 +1,29 @@
+Index: linux-2.6.21.1/drivers/leds/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/drivers/leds/Makefile 2007-07-10 20:56:30.000000000 +0200
++++ linux-2.6.21.1/drivers/leds/Makefile 2007-07-19 16:43:07.000000000 +0200
+@@ -16,6 +16,7 @@
+ obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
+ obj-$(CONFIG_LEDS_H1940) += leds-h1940.o
+ obj-$(CONFIG_LEDS_COBALT) += leds-cobalt.o
++obj-$(CONFIG_LEDS_RB500) += leds-rb500.o
+
+ # LED Triggers
+ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
+Index: linux-2.6.21.1/drivers/leds/Kconfig
+===================================================================
+--- linux-2.6.21.1.orig/drivers/leds/Kconfig 2007-07-10 20:56:30.000000000 +0200
++++ linux-2.6.21.1/drivers/leds/Kconfig 2007-07-19 16:42:55.000000000 +0200
+@@ -95,6 +95,12 @@
+ help
+ This option enables support for the front LED on Cobalt Server
+
++config LEDS_RB500
++ tristate "LED Support for RB5xx boards"
++ depends LEDS_CLASS && MIKROTIK_RB500
++ help
++ This option enables support for the yellow user LED on RB5xx boards.
++
+ comment "LED Triggers"
+
+ config LEDS_TRIGGERS