aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/zynq/profiles/zc702.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-02-12 08:29:24 +0000
committerJohn Crispin <blogic@openwrt.org>2016-02-12 08:29:24 +0000
commitaddbde1976b932f70cf3d2f682e75b55cb1db9e9 (patch)
tree66f8803c741787ca79b5a2b10ad426003c942a5e /target/linux/zynq/profiles/zc702.mk
parentff222b5bd577f6543c172b78d530560cc7bbe48b (diff)
downloadmaster-187ad058-addbde1976b932f70cf3d2f682e75b55cb1db9e9.tar.gz
master-187ad058-addbde1976b932f70cf3d2f682e75b55cb1db9e9.tar.bz2
master-187ad058-addbde1976b932f70cf3d2f682e75b55cb1db9e9.zip
zynq: add new target
Add support for Xilinx ZC702 Dev board Zynq target is using 4.4 kernel and mainline 2016.1 u-boot. Patch is tested with Xilinx ZC702 Dev board with SD boot mode. known issues: - no QSPI driver in 4.4 kernel: no QSPI flash support - USB is not working in 4.4 kernel Signed-off-by: Jason Wu <jason.wu.misc@gmail.com> create mode 100644 package/boot/uboot-zynq/Makefile create mode 100644 target/linux/zynq/Makefile create mode 100644 target/linux/zynq/base-files.mk create mode 100755 target/linux/zynq/base-files/etc/board.d/02_network create mode 100644 target/linux/zynq/base-files/etc/config/network create mode 100644 target/linux/zynq/base-files/etc/inittab create mode 100644 target/linux/zynq/config-4.4 create mode 100644 target/linux/zynq/image/Makefile create mode 100755 target/linux/zynq/image/mkits.sh create mode 100644 target/linux/zynq/patches-4.4/0001-arm-dts-zynq-zc702.dts-Set-default-rdinit-to-sbin-in.patch create mode 100644 target/linux/zynq/profiles/zc702.mk git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48697 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/zynq/profiles/zc702.mk')
-rw-r--r--target/linux/zynq/profiles/zc702.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/zynq/profiles/zc702.mk b/target/linux/zynq/profiles/zc702.mk
new file mode 100644
index 0000000000..9d3c972fa6
--- /dev/null
+++ b/target/linux/zynq/profiles/zc702.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ZC702
+ NAME:=ZC702 development baord
+endef
+
+define Profile/ZC702/Description
+ Build firmware image for Xilinx Zynq ZC702 development board.
+endef
+
+$(eval $(call Profile,ZC702))