aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/xburst/Makefile
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-01-11 04:44:45 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-01-11 04:44:45 +0000
commit4a18a35a91f6650deea92052c9fb74c1b90d7428 (patch)
tree9f8851bc32dbcd5a39bcb13ecf294dff3902aeab /target/linux/xburst/Makefile
parent2710572b04ad8ad7b1e100083efbec70f8b61007 (diff)
downloadmaster-187ad058-4a18a35a91f6650deea92052c9fb74c1b90d7428.tar.gz
master-187ad058-4a18a35a91f6650deea92052c9fb74c1b90d7428.tar.bz2
master-187ad058-4a18a35a91f6650deea92052c9fb74c1b90d7428.zip
Merge xburst target.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19098 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/xburst/Makefile')
-rw-r--r--target/linux/xburst/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
new file mode 100644
index 0000000000..7043be021c
--- /dev/null
+++ b/target/linux/xburst/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=xburst
+BOARDNAME:=XBurst JZ47x0
+FEATURES:=jffs2 tgz ubifs
+
+LINUX_VERSION:=2.6.32
+
+DEVICE_TYPE=other
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=uImage
+
+DEFAULT_PACKAGES += gpioctl
+
+define Target/Description
+ Build firmware images for XBurst JZ47x0 based boards.
+endef
+
+$(eval $(call BuildTarget))