aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-19 01:14:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-19 01:14:45 +0000
commitd3cae4c425eb240d3a25395a79037ae97f80cfae (patch)
treedf9b27ee2da1c997652cbed889855004cb76de01 /target/linux/x86/image/Makefile
parent7b83cebba9c47be80060ecadd82097f4b9370cb2 (diff)
downloadmaster-187ad058-d3cae4c425eb240d3a25395a79037ae97f80cfae.tar.gz
master-187ad058-d3cae4c425eb240d3a25395a79037ae97f80cfae.tar.bz2
master-187ad058-d3cae4c425eb240d3a25395a79037ae97f80cfae.zip
Make the grub timeout configurable on x86 targets
Signed-off-by: Justus Winter <4winter@informatik.uni-hamburg.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29786 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index c070a10319..185da1096c 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -31,6 +31,8 @@ endif
ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
+GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_X86_GRUB_TIMEOUT))
+
ifneq ($(CONFIG_X86_GRUB_IMAGES),)
BOOTOPTS:=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
@@ -64,6 +66,7 @@ ifneq ($(CONFIG_X86_GRUB_IMAGES),)
-e 's#@SERIAL_CONFIG@#$(strip $(GRUB_SERIAL_CONFIG))#g' \
-e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
-e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
+ -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_x86.sh \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \