aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-04-10 14:43:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-04-10 14:43:17 +0000
commit550238fa72614802732a895ac0460f3c96b5c337 (patch)
treefda50f2f73fd091d02f9e46bf171541b387d5661 /target/linux/x86/image/Makefile
parent7cdf7c14d6e32b40514059f8d219a86ed0eb381d (diff)
downloadmaster-187ad058-550238fa72614802732a895ac0460f3c96b5c337.tar.gz
master-187ad058-550238fa72614802732a895ac0460f3c96b5c337.tar.bz2
master-187ad058-550238fa72614802732a895ac0460f3c96b5c337.zip
x86: try harder to attach block2mtd to fix boot issues on devices with longer delays
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40444 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 4b40e64de7..03aa350da2 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -53,15 +53,15 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
endef
define Image/cmdline/jffs2-64k
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
endef
define Image/cmdline/jffs2-128k
- block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
+ block2mtd.block2mtd=$(ROOTPART),131072,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
endef
define Image/cmdline/squashfs
- block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootwait
+ block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=squashfs rootwait
endef
define Image/Build/grub2