aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-06-28 17:54:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-06-28 17:54:44 +0000
commit3f198c6c0e1f8ed135b8b226c2e533f4a3494647 (patch)
treec2cda35393f954ec31b143f9727e588530ea7223 /target/linux/x86/image/Makefile
parent93a27d7477a7223f86587e1e1fa0cfdd1703c5e5 (diff)
downloadmaster-187ad058-3f198c6c0e1f8ed135b8b226c2e533f4a3494647.tar.gz
master-187ad058-3f198c6c0e1f8ed135b8b226c2e533f4a3494647.tar.bz2
master-187ad058-3f198c6c0e1f8ed135b8b226c2e533f4a3494647.zip
x86: don't attempt to compile grub on darwin
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11599 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 6649670df6..d707d2f435 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -14,6 +14,7 @@ ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
+ifneq ($(HOST_OS),Darwin)
define Image/cmdline/squashfs
block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit
endef
@@ -44,9 +45,7 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
PADDING="$(CONFIG_X86_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
$(call Image/Build/grub/$(1))
endef
-endif
-ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
define Image/Prepare/grub
# for the image builder
$(CP) \
@@ -55,6 +54,11 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
$(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/e2fs_stage1_5 \
$(KDIR)/
endef
+else
+ define Image/Build/grub
+ PADDING="$(CONFIG_X86_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" NOGRUB=1 ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) "" $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
+ endef
+endif
endif
ifeq ($(CONFIG_X86_VDI_IMAGES),y)