aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-04-11 12:36:55 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-04-11 12:36:55 +0000
commitaf0b2ec8c791108e4f346422158af8f1a0769392 (patch)
tree4677183fbf623296330b371d6fd841dbc09a7130 /target/linux/x86/Makefile
parentf14bc47ac3b0b0ae53c26b9c1c51af1b8fc23095 (diff)
downloadmaster-187ad058-af0b2ec8c791108e4f346422158af8f1a0769392.tar.gz
master-187ad058-af0b2ec8c791108e4f346422158af8f1a0769392.tar.bz2
master-187ad058-af0b2ec8c791108e4f346422158af8f1a0769392.zip
[x86] add net5501 support
This patch brings up the net5501 platform. Note that the x86/ target included support for all x86/ class processors. That's not technically correct. This should be constrained only to the "generic" subtarget. Every x86-class target that isn't generic should be able to select only the optimizations/capabilities applicable to that architectural variant. It's also assumed that all x86 processors have keyboard & mouse ports, ISA, DMI, ACPI... the embedded ones typically don't. Again, moving that to the generic subtarget. Fortunately, this was a fairly benign tweak. The net5501 board includes the following logic: Geode/LX processor CS5535 super-I/O chip PC87360 sensor chip Via Rhine Ethernet controllers Via Sata controllers USB, LEDS, I2C Signed-off-by: Philip Prindeville <philipp_subx@redfish-solutions.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20794 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/Makefile')
-rw-r--r--target/linux/x86/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 4cf011af78..6b248f68c3 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -10,7 +10,7 @@ ARCH:=i386
BOARD:=x86
BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
-SUBTARGETS=generic olpc xen_domu ep80579
+SUBTARGETS=generic olpc xen_domu ep80579 net5501
LINUX_VERSION:=2.6.32.10