aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-02-12 19:04:16 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-02-12 19:04:16 +0000
commit5b3c56369e957a325b484b92abc4d08c77cd205c (patch)
tree49c3bea157d06bc8c9d93fc527423f0457df23c8 /target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch
parent2088a05c66fb9f7a51ecb77f57308dafaa2b5a0f (diff)
downloadmaster-187ad058-5b3c56369e957a325b484b92abc4d08c77cd205c.tar.gz
master-187ad058-5b3c56369e957a325b484b92abc4d08c77cd205c.tar.bz2
master-187ad058-5b3c56369e957a325b484b92abc4d08c77cd205c.zip
[uml] add 2.6.37 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25484 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch')
-rw-r--r--target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch b/target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch
new file mode 100644
index 0000000000..2be33d02a3
--- /dev/null
+++ b/target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch
@@ -0,0 +1,21 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
++
+ KBUILD_CFLAGS += $(cflags-y)
+--- a/arch/um/Makefile-x86_64
++++ b/arch/um/Makefile-x86_64
+@@ -24,3 +24,7 @@ LINK-y += -m64
+
+ # Do unit-at-a-time unconditionally on x86_64, following the host
+ KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
++
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)