aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml-2.6/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
commit53aef8417d5b9e00e4b74b022ed03975c732d8e9 (patch)
tree56570ca509d7826cb8163622a96ddac70562068c /target/linux/uml-2.6/image
parentbf32023e6c902f04f995d7e787a72129794a16ba (diff)
downloadmaster-187ad058-53aef8417d5b9e00e4b74b022ed03975c732d8e9.tar.gz
master-187ad058-53aef8417d5b9e00e4b74b022ed03975c732d8e9.tar.bz2
master-187ad058-53aef8417d5b9e00e4b74b022ed03975c732d8e9.zip
Add initial version of the new Image Builder
It's still a bit rough in a few places, but it seems to work for Broadcom at least - other targets untested. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6071 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/uml-2.6/image')
-rwxr-xr-xtarget/linux/uml-2.6/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/uml-2.6/image/Makefile b/target/linux/uml-2.6/image/Makefile
index 6af4b8b816..b7bd9e9e65 100755
--- a/target/linux/uml-2.6/image/Makefile
+++ b/target/linux/uml-2.6/image/Makefile
@@ -7,9 +7,13 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+define Image/Prepare
+ cp $(LINUX_DIR)/linux $(KDIR)/vmlinux.elf
+endef
+
define Image/Build
cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
- cp $(LINUX_DIR)/linux $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
endef
$(eval $(call BuildImage))