aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml-2.6/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-28 18:25:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-28 18:25:14 +0000
commit556ff80527f0f825b2f1c19072668443e36b3a5c (patch)
tree24de3aa7937cf3da47acf8f1318e29efac534501 /target/linux/uml-2.6/Makefile
parent1bde0390cfc1b2befe28803e8caf01dffc01beba (diff)
downloadmaster-187ad058-556ff80527f0f825b2f1c19072668443e36b3a5c.tar.gz
master-187ad058-556ff80527f0f825b2f1c19072668443e36b3a5c.tar.bz2
master-187ad058-556ff80527f0f825b2f1c19072668443e36b3a5c.zip
mark uml as broken and add some cleanups (not working yet)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6439 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/uml-2.6/Makefile')
-rw-r--r--target/linux/uml-2.6/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/target/linux/uml-2.6/Makefile b/target/linux/uml-2.6/Makefile
index 33bf8060fe..25624108ab 100644
--- a/target/linux/uml-2.6/Makefile
+++ b/target/linux/uml-2.6/Makefile
@@ -5,10 +5,25 @@
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/host.mk
-ARCH:=i386
+# UML only makes sense on linux
+ifeq ($(HOST_OS),Linux)
+
+ARCH:=$(shell uname -m | sed \
+ -e 's/i[3-9]86/i386/' \
+ -e 's/mipsel/mips/' \
+ -e 's/mipseb/mips/' \
+ -e 's/powerpc/ppc/' \
+ -e 's/sh[234]/sh/' \
+ -e 's/armeb/arm/' \
+)
BOARD:=uml
BOARDNAME:=User Mode Linux
+FEATURES:=broken
+LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
include $(INCLUDE_DIR)/kernel-build.mk
+endif
+
$(eval $(call BuildKernel))