aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-11-05 08:00:34 +0000
committerLuka Perkov <luka@openwrt.org>2013-11-05 08:00:34 +0000
commit4a7d83ad5e3a377885ad6c9a4c1ddae38c3614bc (patch)
tree1c7f2764ec5c47e1a573ffbbd52f9332c0ae4574 /target/linux/sunxi/Makefile
parent6d6902cac104e69346389207cf106d3d51d9dd1b (diff)
downloadmaster-187ad058-4a7d83ad5e3a377885ad6c9a4c1ddae38c3614bc.tar.gz
master-187ad058-4a7d83ad5e3a377885ad6c9a4c1ddae38c3614bc.tar.bz2
master-187ad058-4a7d83ad5e3a377885ad6c9a4c1ddae38c3614bc.zip
sunxi: add new target
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38651 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/sunxi/Makefile')
-rw-r--r--target/linux/sunxi/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/sunxi/Makefile b/target/linux/sunxi/Makefile
new file mode 100644
index 0000000000..bff78e5ee6
--- /dev/null
+++ b/target/linux/sunxi/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=sunxi
+BOARDNAME:=Allwinner SoC
+FEATURES:=targz
+SUBTARGETS=cortex-a7 cortex-a8
+MAINTAINER:=Luka Perkov <luka@openwrt.org>
+
+LINUX_VERSION:=3.10.17
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="zImage dtbs"
+
+$(eval $(call BuildTarget))