aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/socfpga/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2016-05-10 22:52:00 +0000
committerLuka Perkov <luka@openwrt.org>2016-06-19 19:35:42 +0200
commit9ccd1da444ff320abf069322b6063d7d041cdd20 (patch)
tree6e4bf314ba8e2ae7ffd68f166a46977aad676ec8 /target/linux/socfpga/Makefile
parentc3d9ae93fd2cfb51ae3e843487edad81545afca4 (diff)
downloadmaster-187ad058-9ccd1da444ff320abf069322b6063d7d041cdd20.tar.gz
master-187ad058-9ccd1da444ff320abf069322b6063d7d041cdd20.tar.bz2
master-187ad058-9ccd1da444ff320abf069322b6063d7d041cdd20.zip
target: socfpga: Add Altera SoCFPGA support
This patch adds support for the Altera SoCFPGA target. Both generic target and Terasic SoCkit boards are supported. Signed-off-by: Marek Vasut <marex@denx.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49367 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/socfpga/Makefile')
-rw-r--r--target/linux/socfpga/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/socfpga/Makefile b/target/linux/socfpga/Makefile
new file mode 100644
index 0000000000..6d75a4bc25
--- /dev/null
+++ b/target/linux/socfpga/Makefile
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=socfpga
+BOARDNAME:=Altera SoCFPGA
+FEATURES:=display fpu gpio rtc usb usbgadget targz ext4 ubifs ramdisk
+CPU_TYPE:=cortex-a9
+CPU_SUBTYPE:=neon
+MAINTAINER:=Marek Vasut <marex@denx.de>
+DEVICE_TYPE:=other
+
+KERNEL_PATCHVER:=4.4
+KERNELNAME:=zImage dtbs
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += \
+ uboot-envtools \
+ ubi-utils \
+ kmod-button-hotplug \
+ kmod-ledtrig-netdev \
+ kmod-usb-core \
+ kmod-usb-dwc2 \
+ kmod-usb-phy-nop \
+ kmod-usb-gadget \
+ kmod-usb-lib-composite \
+ kmod-usb-storage \
+ kmod-usb-storage-gadget \
+ dnsmasq iptables ip6tables \
+ kmod-nf-nathelper firewall \
+ odhcpd odhcp6c
+
+$(eval $(call BuildTarget))