aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532/patches-2.6.24/510-rb500_led.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-07-15 17:18:28 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-07-15 17:18:28 +0000
commit84ee0935744035d586676b5eb0f34ca338bedb8a (patch)
treed9739f3e39aff522c95b81398ef01375c26a11b3 /target/linux/rb532/patches-2.6.24/510-rb500_led.patch
parentbb34f3521e9c8328772ab19afcb1a1b666631fd6 (diff)
downloadmaster-187ad058-84ee0935744035d586676b5eb0f34ca338bedb8a.tar.gz
master-187ad058-84ee0935744035d586676b5eb0f34ca338bedb8a.tar.bz2
master-187ad058-84ee0935744035d586676b5eb0f34ca338bedb8a.zip
Add basic 2.6.24 support for rb532, korina napi code has to be adapted to work
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11844 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rb532/patches-2.6.24/510-rb500_led.patch')
-rw-r--r--target/linux/rb532/patches-2.6.24/510-rb500_led.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/rb532/patches-2.6.24/510-rb500_led.patch b/target/linux/rb532/patches-2.6.24/510-rb500_led.patch
new file mode 100644
index 0000000000..6cd7b1a1c5
--- /dev/null
+++ b/target/linux/rb532/patches-2.6.24/510-rb500_led.patch
@@ -0,0 +1,27 @@
+diff -urN linux-2.6.24.7/drivers/leds/Kconfig linux-2.6.24.7.new/drivers/leds/Kconfig
+--- linux-2.6.24.7/drivers/leds/Kconfig 2008-07-15 15:27:55.000000000 +0200
++++ linux-2.6.24.7.new/drivers/leds/Kconfig 2008-07-15 15:35:24.000000000 +0200
+@@ -120,6 +120,12 @@
+ help
+ This option enables support for the CM-X270 LEDs.
+
++config LEDS_RB500
++ tristate "LED Support for RB5xx boards"
++ depends on LEDS_CLASS && MIKROTIK_RB500
++ help
++ This option enables support for the yellow user LED on RB5xx boards.
++
+ comment "LED Triggers"
+
+ config LEDS_TRIGGERS
+diff -urN linux-2.6.24.7/drivers/leds/Makefile linux-2.6.24.7.new/drivers/leds/Makefile
+--- linux-2.6.24.7/drivers/leds/Makefile 2008-07-15 15:27:55.000000000 +0200
++++ linux-2.6.24.7.new/drivers/leds/Makefile 2008-07-15 15:35:38.000000000 +0200
+@@ -20,6 +20,7 @@
+ obj-$(CONFIG_LEDS_COBALT_RAQ) += leds-cobalt-raq.o
+ obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
+ obj-$(CONFIG_LEDS_CM_X270) += leds-cm-x270.o
++obj-$(CONFIG_LEDS_RB500) += leds-rb500.o
+
+ # LED Triggers
+ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o