aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532/patches-2.6.23/520-rc32434_wdt.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-07-15 17:17:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-07-15 17:17:04 +0000
commitbb34f3521e9c8328772ab19afcb1a1b666631fd6 (patch)
tree03c3dac161ce721fd65cb2f2d967eda861999b74 /target/linux/rb532/patches-2.6.23/520-rc32434_wdt.patch
parent8deed3752fab08ca2fcb324c11834aa3f199510f (diff)
downloadmaster-187ad058-bb34f3521e9c8328772ab19afcb1a1b666631fd6.tar.gz
master-187ad058-bb34f3521e9c8328772ab19afcb1a1b666631fd6.tar.bz2
master-187ad058-bb34f3521e9c8328772ab19afcb1a1b666631fd6.zip
Move files and patches to files-2.6.23 and patches-2.6.23
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11843 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rb532/patches-2.6.23/520-rc32434_wdt.patch')
-rw-r--r--target/linux/rb532/patches-2.6.23/520-rc32434_wdt.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/target/linux/rb532/patches-2.6.23/520-rc32434_wdt.patch b/target/linux/rb532/patches-2.6.23/520-rc32434_wdt.patch
new file mode 100644
index 0000000000..3ea431490e
--- /dev/null
+++ b/target/linux/rb532/patches-2.6.23/520-rc32434_wdt.patch
@@ -0,0 +1,46 @@
+Index: linux-2.6.23.17/arch/mips/kernel/time.c
+===================================================================
+--- linux-2.6.23.17.orig/arch/mips/kernel/time.c
++++ linux-2.6.23.17/arch/mips/kernel/time.c
+@@ -479,3 +479,5 @@ EXPORT_SYMBOL(rtc_lock);
+ EXPORT_SYMBOL(to_tm);
+ EXPORT_SYMBOL(rtc_mips_set_time);
+ EXPORT_SYMBOL(rtc_mips_get_time);
++EXPORT_SYMBOL(mips_hpt_frequency);
++
+Index: linux-2.6.23.17/drivers/watchdog/Kconfig
+===================================================================
+--- linux-2.6.23.17.orig/drivers/watchdog/Kconfig
++++ linux-2.6.23.17/drivers/watchdog/Kconfig
+@@ -647,6 +647,19 @@ config WATCHDOG_RTAS
+ To compile this driver as a module, choose M here. The module
+ will be called wdrtas.
+
++config RC32434_WDT
++ tristate "IDT Interprise 79RC32434 SoC hardware watchdog"
++ depends on WATCHDOG && MIKROTIK_RB500
++ help
++ This is a driver for hardware watchdog integrated in IDT Interprise
++ 79RC32434 SoC. This watchdog simply watches your kernel to make sure
++ it doesn't freeze, and if it does, it reboots your computer after a
++ certain amount of time.
++
++ To compile this driver as a module, choose M here: the module will be
++ called rc32434_wdt.
++
++
+ # S390 Architecture
+
+ config ZVM_WATCHDOG
+Index: linux-2.6.23.17/drivers/watchdog/Makefile
+===================================================================
+--- linux-2.6.23.17.orig/drivers/watchdog/Makefile
++++ linux-2.6.23.17/drivers/watchdog/Makefile
+@@ -90,6 +90,7 @@ obj-$(CONFIG_SBC_EPX_C3_WATCHDOG) += sbc
+ obj-$(CONFIG_INDYDOG) += indydog.o
+ obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
+ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
++obj-$(CONFIG_RC32434_WDT) += rc32434_wdt.o
+
+ # PARISC Architecture
+