aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532/patches-2.6.23/510-rb500_led.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-07-15 17:17:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-07-15 17:17:04 +0000
commitbb34f3521e9c8328772ab19afcb1a1b666631fd6 (patch)
tree03c3dac161ce721fd65cb2f2d967eda861999b74 /target/linux/rb532/patches-2.6.23/510-rb500_led.patch
parent8deed3752fab08ca2fcb324c11834aa3f199510f (diff)
downloadmaster-187ad058-bb34f3521e9c8328772ab19afcb1a1b666631fd6.tar.gz
master-187ad058-bb34f3521e9c8328772ab19afcb1a1b666631fd6.tar.bz2
master-187ad058-bb34f3521e9c8328772ab19afcb1a1b666631fd6.zip
Move files and patches to files-2.6.23 and patches-2.6.23
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11843 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rb532/patches-2.6.23/510-rb500_led.patch')
-rw-r--r--target/linux/rb532/patches-2.6.23/510-rb500_led.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/rb532/patches-2.6.23/510-rb500_led.patch b/target/linux/rb532/patches-2.6.23/510-rb500_led.patch
new file mode 100644
index 0000000000..714c112a76
--- /dev/null
+++ b/target/linux/rb532/patches-2.6.23/510-rb500_led.patch
@@ -0,0 +1,29 @@
+Index: linux-2.6.23.17/drivers/leds/Kconfig
+===================================================================
+--- linux-2.6.23.17.orig/drivers/leds/Kconfig
++++ linux-2.6.23.17/drivers/leds/Kconfig
+@@ -107,6 +107,12 @@ config LEDS_GPIO
+ outputs. To be useful the particular board must have LEDs
+ and they must be connected to the GPIO lines.
+
++config LEDS_RB500
++ tristate "LED Support for RB5xx boards"
++ depends LEDS_CLASS && MIKROTIK_RB500
++ help
++ This option enables support for the yellow user LED on RB5xx boards.
++
+ comment "LED Triggers"
+
+ config LEDS_TRIGGERS
+Index: linux-2.6.23.17/drivers/leds/Makefile
+===================================================================
+--- linux-2.6.23.17.orig/drivers/leds/Makefile
++++ linux-2.6.23.17/drivers/leds/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_LEDS_ALIX) += leds-alix.o
+ obj-$(CONFIG_LEDS_H1940) += leds-h1940.o
+ obj-$(CONFIG_LEDS_COBALT) += leds-cobalt.o
+ obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
++obj-$(CONFIG_LEDS_RB500) += leds-rb500.o
+
+ # LED Triggers
+ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o