aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532-2.6/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-07-19 14:53:24 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-07-19 14:53:24 +0000
commit8e5e2d5996572c8d2bd840259fd0eaef155584a0 (patch)
tree4667a909ea50585b7447b1c0496eac978afbbf5e /target/linux/rb532-2.6/image
parent48281586b9bf513f70fdfc7cc40f624e8ee52f40 (diff)
downloadmaster-187ad058-8e5e2d5996572c8d2bd840259fd0eaef155584a0.tar.gz
master-187ad058-8e5e2d5996572c8d2bd840259fd0eaef155584a0.tar.bz2
master-187ad058-8e5e2d5996572c8d2bd840259fd0eaef155584a0.zip
Convert the NAND driver to platform_driver, allow tgz image to be built correctly
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8058 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rb532-2.6/image')
-rw-r--r--target/linux/rb532-2.6/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index 555eb2a645..a9e2b9575c 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -49,9 +49,16 @@ define Image/cmdline/squashfs
block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit
endef
+# TGZ images should be used with a yaffs2 rootfs
+define Image/cmdline/tgz
+root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
+endef
+
define Image/Build
$(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
+ifneq ($(1),tgz)
./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
+endif
endef
$(eval $(call BuildImage))