aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532-2.6/base-files.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-06 18:31:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-06 18:31:28 +0000
commitdecda6f17f46f8828ea38d16a49717d2a77910e7 (patch)
tree90a4c4a25d820e450f23fec4bc08441ffc1ae871 /target/linux/rb532-2.6/base-files.mk
parentede0d279ad9d5bf0cdb696000baa75e3faaec02a (diff)
downloadmaster-187ad058-decda6f17f46f8828ea38d16a49717d2a77910e7.tar.gz
master-187ad058-decda6f17f46f8828ea38d16a49717d2a77910e7.tar.bz2
master-187ad058-decda6f17f46f8828ea38d16a49717d2a77910e7.zip
replace the ugly rb532 cmdline hack with a cleaner one that does not depend on magic offsets
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5699 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rb532-2.6/base-files.mk')
-rw-r--r--target/linux/rb532-2.6/base-files.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/rb532-2.6/base-files.mk b/target/linux/rb532-2.6/base-files.mk
new file mode 100644
index 0000000000..afd1220c56
--- /dev/null
+++ b/target/linux/rb532-2.6/base-files.mk
@@ -0,0 +1,11 @@
+define Build/Compile
+ $(call Build/Compile/Default)
+ $(TARGET_CC) -o $(PKG_BUILD_DIR)/patch-cmdline $(PLATFORM_DIR)/src/patch-cmdline.c
+endef
+
+define Package/base-files/install-target
+ mkdir -p $(1)/sbin
+ $(CP) $(PKG_BUILD_DIR)/patch-cmdline $(1)/sbin
+endef
+
+