aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-07-22 15:36:39 +0000
committerJohn Crispin <blogic@openwrt.org>2013-07-22 15:36:39 +0000
commita6fc8d2e4d92c3d82763dad102916f10b1aa8627 (patch)
tree93c7d19fba0dedc2ebfb62a944525b4506647c15 /target/linux/ramips/rt305x
parentd6e3e9ba4d05fea4e5080d6d585e93f56beae6da (diff)
downloadmaster-187ad058-a6fc8d2e4d92c3d82763dad102916f10b1aa8627.tar.gz
master-187ad058-a6fc8d2e4d92c3d82763dad102916f10b1aa8627.tar.bz2
master-187ad058-a6fc8d2e4d92c3d82763dad102916f10b1aa8627.zip
ramips: Add support for Huawei HG255D in trunk
HG255D is a kind of popular low-end home gateway in China, this patch bring the the trunk support for it. It is adapted from a local Chinese community (www.right.com.cn), so credit should given to them. This patch is tested to work except trivial LED issues. Signed-off-by: Leon Xu <ylxu72@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37505 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/hg255d.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/hg255d.mk b/target/linux/ramips/rt305x/profiles/hg255d.mk
new file mode 100644
index 0000000000..9aebe093ce
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/hg255d.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/HG255D
+ NAME:=HuaWei HG255D
+ PACKAGES:=kmod-leds-gpio kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+define Profile/HG255D/Description
+ Package set for HuaWei HG255D.
+endef
+
+$(eval $(call Profile,HG255D))