aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-4.3/0103-MIPS-OWRTDTB.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-10 19:06:32 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-10 19:06:32 +0000
commit930035f9fa98f438a71337f707fc43316318a1be (patch)
treea0bd281424429737ec1fd7597733e138780f09ac /target/linux/ramips/patches-4.3/0103-MIPS-OWRTDTB.patch
parent61721e21887ea266acd057e4343f5977c29e209b (diff)
downloadmaster-187ad058-930035f9fa98f438a71337f707fc43316318a1be.tar.gz
master-187ad058-930035f9fa98f438a71337f707fc43316318a1be.tar.bz2
master-187ad058-930035f9fa98f438a71337f707fc43316318a1be.zip
ralink: bump to the target to v4.3
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47831 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/patches-4.3/0103-MIPS-OWRTDTB.patch')
-rw-r--r--target/linux/ramips/patches-4.3/0103-MIPS-OWRTDTB.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-4.3/0103-MIPS-OWRTDTB.patch b/target/linux/ramips/patches-4.3/0103-MIPS-OWRTDTB.patch
new file mode 100644
index 0000000000..b90138317b
--- /dev/null
+++ b/target/linux/ramips/patches-4.3/0103-MIPS-OWRTDTB.patch
@@ -0,0 +1,44 @@
+From c174d2250e402399ad7dbdd57d51883d8804bba0 Mon Sep 17 00:00:00 2001
+From: John Crispin <blogic@openwrt.org>
+Date: Mon, 15 Jul 2013 00:40:37 +0200
+Subject: [PATCH 31/33] owrt: MIPS: add OWRTDTB secion
+
+Signed-off-by: John Crispin <blogic@openwrt.org>
+---
+ arch/mips/kernel/head.S | 3 +++
+ arch/mips/ralink/Makefile | 2 +-
+ arch/mips/ralink/of.c | 4 +++-
+ 3 files changed, 7 insertions(+), 2 deletions(-)
+
+--- a/arch/mips/kernel/head.S
++++ b/arch/mips/kernel/head.S
+@@ -86,6 +86,9 @@ EXPORT(__image_cmdline)
+ .fill 0x400
+ #endif /* CONFIG_IMAGE_CMDLINE_HACK */
+
++ .ascii "OWRTDTB:"
++ EXPORT(__image_dtb)
++ .fill 0x4000
+ __REF
+
+ NESTED(kernel_entry, 16, sp) # kernel entry point
+--- a/arch/mips/ralink/of.c
++++ b/arch/mips/ralink/of.c
+@@ -66,6 +66,8 @@ static int __init early_init_dt_find_mem
+ return 0;
+ }
+
++extern struct boot_param_header __image_dtb;
++
+ void __init plat_mem_setup(void)
+ {
+ set_io_port_base(KSEG1);
+@@ -74,7 +76,7 @@ void __init plat_mem_setup(void)
+ * Load the builtin devicetree. This causes the chosen node to be
+ * parsed resulting in our memory appearing
+ */
+- __dt_setup_arch(__dtb_start);
++ __dt_setup_arch(&__image_dtb);
+
+ strlcpy(arcs_cmdline, boot_command_line, COMMAND_LINE_SIZE);
+