aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-26 11:43:53 +0000
committerJohn Crispin <blogic@openwrt.org>2016-04-26 11:43:53 +0000
commit518aa56669618d97429d8f8c62c4a162a53bc3b1 (patch)
treedbfdcd21a85c995110269f2fc1720ef6b66271a6 /target/linux/ramips/mt7621/profiles
parentcd553a2a7bc68edee8c7dcc8ea385daed971c742 (diff)
downloadmaster-187ad058-518aa56669618d97429d8f8c62c4a162a53bc3b1.tar.gz
master-187ad058-518aa56669618d97429d8f8c62c4a162a53bc3b1.tar.bz2
master-187ad058-518aa56669618d97429d8f8c62c4a162a53bc3b1.zip
ramips: Add support for the Netgear WNDR3700v5
https://wiki.openwrt.org/toh/netgear/wndr3700 wndr3700v5 uses the single-core dual thread MediaTek MT7621S SoC. Signed-off-by: L. D. Pinney <ldpinney@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49247 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7621/profiles')
-rw-r--r--target/linux/ramips/mt7621/profiles/netgear.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/netgear.mk b/target/linux/ramips/mt7621/profiles/netgear.mk
new file mode 100644
index 0000000000..05802a252f
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/netgear.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WNDR3700V5
+ NAME:=Netgear WNDR3700v5
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3
+endef
+
+define Profile/WNDR3700V5/Description
+ Package set compatible with the Netgear WNDR3700v5.
+endef
+$(eval $(call Profile,WNDR3700V5))