aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-06-18 18:20:40 +0000
committerJohn Crispin <blogic@openwrt.org>2015-06-18 18:20:40 +0000
commit3b140c6fe45781d79cebe3c2ef6208f5d556b6bb (patch)
tree36d8e78be2d8938670758b285e9d644e92b9eac2 /target/linux/ramips/mt7621/profiles
parent0dc621e3d97f9e9ca5ed68c2c08f695f6ae408a7 (diff)
downloadmaster-187ad058-3b140c6fe45781d79cebe3c2ef6208f5d556b6bb.tar.gz
master-187ad058-3b140c6fe45781d79cebe3c2ef6208f5d556b6bb.tar.bz2
master-187ad058-3b140c6fe45781d79cebe3c2ef6208f5d556b6bb.zip
ramips: add support for PandoraBox PBR-M1
This patch is for PandoraBox PBR-M1 which is based on mt7621, all the features work fine, including rtc, leds, button, usb3.0, etc. Signed-off-by: tymon <banglang.huang@foxmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46041 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7621/profiles')
-rw-r--r--target/linux/ramips/mt7621/profiles/pbr-m1.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/pbr-m1.mk b/target/linux/ramips/mt7621/profiles/pbr-m1.mk
new file mode 100644
index 0000000000..5b4dfb58cf
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/pbr-m1.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/PBR-M1
+ NAME:=PBR-M1 Device
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev kmod-mt76 kmod-ata-core kmod-ata-ahci \
+ kmod-usb3-mt7621 kmod-rtc-pcf8563
+endef
+
+
+FEATURES+=rtc
+
+define Profile/PBR-M1/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,PBR-M1))