aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-11-24 18:29:26 +0000
committerJohn Crispin <blogic@openwrt.org>2015-11-24 18:29:26 +0000
commit1a5d8c271f351f8dc8679a68a969b0fe6c3cad62 (patch)
tree599c91c85fb465a3718129fc7866ba73263f5cff /target/linux/ramips/mt7621/profiles
parent28a7ad2f506a4bb3b736b7a74eafebe12d67bb72 (diff)
downloadmaster-187ad058-1a5d8c271f351f8dc8679a68a969b0fe6c3cad62.tar.gz
master-187ad058-1a5d8c271f351f8dc8679a68a969b0fe6c3cad62.tar.bz2
master-187ad058-1a5d8c271f351f8dc8679a68a969b0fe6c3cad62.zip
ralink: add support for netis WF-2881
netis WF-2881 is an MT7621AT based router with MT7602EN, MT7612EN. It has 128MB DDR3, 128MB SLC NAND FLASH, 5-port Gbps switch and 1x USB 3.0. The following patch adds support for this device. this device only works on top of UBI. Tested and working: * ethernet * both WiFi radios * USB 3.0 * buttons (reset button) * ethernet switch and USB diag LEDs * UART * GPIOs * sysupgrade Tested and not working * failsafe Signed-off-by: YounJae Rho <luxflow@live.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47619 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7621/profiles')
-rw-r--r--target/linux/ramips/mt7621/profiles/netis.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/netis.mk b/target/linux/ramips/mt7621/profiles/netis.mk
new file mode 100644
index 0000000000..39b524f534
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/netis.mk
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WF-2881
+ NAME:=NETIS WF-2881
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/WF-2881/Description
+ Package set compatible with the NETIS WF-2881 board.
+endef
+
+#-m <min io size> -e <LEB size> -c <Eraseblocks count>
+WF-2881_UBIFS_OPTS:="-m 2048 -e 129024 -c 1024"
+WF-2881_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,WF-2881))