aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-09 10:32:37 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-09 10:32:37 +0000
commitbd60aa0e69df782a291d6ea7a55495898ee78c4d (patch)
tree0043197b0b6542e1c755035574af0c0772630944 /target/linux/ramips/mt7620
parente9d844e3e8cfeb864ce87d85466bf57eadb4bf96 (diff)
downloadmaster-187ad058-bd60aa0e69df782a291d6ea7a55495898ee78c4d.tar.gz
master-187ad058-bd60aa0e69df782a291d6ea7a55495898ee78c4d.tar.bz2
master-187ad058-bd60aa0e69df782a291d6ea7a55495898ee78c4d.zip
ramips: Add support for Microduino MicroWRT
MicroWRT is an wireless router with 2 USB,1 ethernet port. It has a 16M flash and 64M DDR2 RAM. You can use most interface, such as i2c, SPI, i2s and PCIe. Besides that there are three expansion borad to combine with the core board. The detailed information, please refer to https://www.microduino.cc/wiki/index.php?title=Main_Page This patch adds support for it. Because there is only one port,so disabled VLAN and use eth0 as lan port. and only a power LED control by power pin. Signed-off-by: 盛凯 <shengkai81@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45331 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/microwrt.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/microwrt.mk b/target/linux/ramips/mt7620/profiles/microwrt.mk
new file mode 100644
index 0000000000..2b0977d669
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/microwrt.mk
@@ -0,0 +1,9 @@
+define Profile/MicroWRT
+ NAME:=Microduino MicroWRT
+ PACKAGES:= kmod-usb-core kmod-usb2 kmod-usb-ohci
+endef
+
+define Profile/MicroWRT/Description
+ Package set compatible with MicroWRT
+endef
+$(eval $(call Profile,MicroWRT))