aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-05 10:26:02 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-05 10:26:02 +0000
commit466b2b08ed6067816be5e80df7031b2b526a660a (patch)
treee5809f8dcd31300d093da84d303f8c7d8c1d2182 /target/linux/ramips/mt7620
parent9b5f8490ee983072628cc46e517315ee239b0685 (diff)
downloadmaster-187ad058-466b2b08ed6067816be5e80df7031b2b526a660a.tar.gz
master-187ad058-466b2b08ed6067816be5e80df7031b2b526a660a.tar.bz2
master-187ad058-466b2b08ed6067816be5e80df7031b2b526a660a.zip
ramips: Add build files for HiWiFi HC5x61 models
HiWiFi HC5661/5761/5861 models are manufactured by http://www.hiwifi.com <http://www.hiwifi.com/>. These models have similar hardware specs(MT7620A + 128M DDR2 + 16M flash). This patch adds support for them. The original author is Justin Liu (rssnsj@gmail.com). I ported the patch to trunk and submitted it here with his approval. v3 fix 1: Spaces -> Tabs 2: Removed some packages Signed-off-by: Xiaoning Kang <kangxn@163.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47113 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/hiwifi.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/hiwifi.mk b/target/linux/ramips/mt7620/profiles/hiwifi.mk
new file mode 100644
index 0000000000..5baa85ae88
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/hiwifi.mk
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/HC5661
+ NAME:=HiWiFi HC5661
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-dwc2 kmod-usb2 \
+ kmod-mmc-spi kmod-sdhci kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/HC5661/Description
+ Support HiWiFi HC5661 model(J1S)
+endef
+$(eval $(call Profile,HC5661))
+
+
+define Profile/HC5761
+ NAME:=HiWiFi HC5761
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-dwc2 kmod-usb2 \
+ kmod-mmc-spi kmod-sdhci kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/HC5761/Description
+ Support HiWiFi HC5761 model(J2)
+endef
+$(eval $(call Profile,HC5761))
+
+
+define Profile/HC5861
+ NAME:=HiWiFi HC5861
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-dwc2 kmod-usb2 \
+ kmod-mmc-spi kmod-sdhci kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/HC5861/Description
+ Support HiWiFi HC5861 model(J3)
+endef
+$(eval $(call Profile,HC5861))