aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-01 09:17:06 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-01 09:17:06 +0000
commit1c9268405ea006c8ac01c6cfef1774070ebafada (patch)
tree62acf38eaf00e5b51615548fb3f67995d08b37c0 /target/linux/ramips/mt7620
parent6a47427d7c471bcd274a1e41f91a32845feec34a (diff)
downloadmaster-187ad058-1c9268405ea006c8ac01c6cfef1774070ebafada.tar.gz
master-187ad058-1c9268405ea006c8ac01c6cfef1774070ebafada.tar.bz2
master-187ad058-1c9268405ea006c8ac01c6cfef1774070ebafada.zip
ramips: Added support for ZBT-826 / ZBT-1026
Support for these MT7620-based routers: https://wiki.openwrt.org/toh/zbt/we-826 Based on Oskari’s patches found here: https://dev.openwrt.org/ticket/19996 Signed-off-by: Jamie Stuart <jamie@onebillion.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48865 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/zbt.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/zbt.mk b/target/linux/ramips/mt7620/profiles/zbt.mk
new file mode 100644
index 0000000000..c33048f4ab
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/zbt.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ZBT-WE826
+ NAME:=ZBT-WE826 Device
+ PACKAGES:=\
+ kmod-scsi-core kmod-scsi-generic kmod-mmc kmod-sdhci \
+ block-mount kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci \
+ kmod-mt76
+endef
+
+define Profile/ZBT-WE826/Description
+ Support for ZBT WE-826-(B,T) routers
+endef
+$(eval $(call Profile,ZBT-WE826))