aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-10 19:11:57 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-10 19:11:57 +0000
commitca34f057d5d74727504b71b0416a98e8e579647e (patch)
tree72ce4bdcaee9b2a5ccd9c910419e6121660814ec /target/linux/ramips/mt7620/profiles
parent55c02b33b2fb42180f4e38aceea396e20ccd829c (diff)
downloadmaster-187ad058-ca34f057d5d74727504b71b0416a98e8e579647e.tar.gz
master-187ad058-ca34f057d5d74727504b71b0416a98e8e579647e.tar.bz2
master-187ad058-ca34f057d5d74727504b71b0416a98e8e579647e.zip
ramips: Add support for GL-MT300A
This patches adds support for GL-MT300A. GL-MT300A is powered by MT7620A. It has 16MB flash, 128MB RAM, Two LANs, USB, UART and MMC daughter board. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48992 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7620/profiles')
-rw-r--r--target/linux/ramips/mt7620/profiles/gli.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/gli.mk b/target/linux/ramips/mt7620/profiles/gli.mk
new file mode 100644
index 0000000000..53e2e9d578
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/gli.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/GL-MT300A
+ NAME:=GL-MT300A
+ PACKAGES:=kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci kmod-mt76
+endef
+
+define Profile/GL-MT300A/Description
+ Support for gl-mt300a Router
+endef
+$(eval $(call Profile,GL-MT300A))