aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-02-12 08:29:33 +0000
committerJohn Crispin <blogic@openwrt.org>2016-02-12 08:29:33 +0000
commit4ba599daa6be5b85eeb9909fcd7090fdd2cec841 (patch)
tree0ab9b9eb7d1a3a4a5cc9ba06e1f07ee9ad8f4f60 /target/linux/ramips/mt7620/profiles
parentaddbde1976b932f70cf3d2f682e75b55cb1db9e9 (diff)
downloadmaster-187ad058-4ba599daa6be5b85eeb9909fcd7090fdd2cec841.tar.gz
master-187ad058-4ba599daa6be5b85eeb9909fcd7090fdd2cec841.tar.bz2
master-187ad058-4ba599daa6be5b85eeb9909fcd7090fdd2cec841.zip
ramips: Add support for Netgear EX2700
This patch adds support for the Netgear EX2700 and builds an approriate sysupgrade image. What's missing is the option to build a factory image flashable via the router's stock web interface, but this approach is hindered by the fact that u-boot operforms an additional integrity check, which expects a uImage header in the last 64 bytes of the "kernel" partition, which the bootloader expects to be 960k, a size exceeded by the standard OpenWrt kernel. Signed-off-by: Joseph C. Lehner <joseph.c.lehner@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48698 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7620/profiles')
-rw-r--r--target/linux/ramips/mt7620/profiles/netgear.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/netgear.mk b/target/linux/ramips/mt7620/profiles/netgear.mk
new file mode 100644
index 0000000000..d1b073abc2
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/netgear.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/EX2700
+ NAME:=Netgear EX2700
+ PACKAGES:=-kmod-usb-core -kmod-usb2 -kmod-usb-ohci -kmod-ledtrig-usbdev
+endef
+
+define Profile/EX2700/Description
+ Support for Netgear EX2700
+endef
+$(eval $(call Profile,EX2700))