aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620/profiles/planex.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-26 11:43:01 +0000
committerJohn Crispin <blogic@openwrt.org>2016-04-26 11:43:01 +0000
commit59d9e3f4994552368fd551c2fa795f43bc1dd9b5 (patch)
tree73ba65383a868869bd5ab612d1f34d1297983558 /target/linux/ramips/mt7620/profiles/planex.mk
parent08fe019a4c3dee78a885f0d92287c94e8ec9f6a1 (diff)
downloadmaster-187ad058-59d9e3f4994552368fd551c2fa795f43bc1dd9b5.tar.gz
master-187ad058-59d9e3f4994552368fd551c2fa795f43bc1dd9b5.tar.bz2
master-187ad058-59d9e3f4994552368fd551c2fa795f43bc1dd9b5.zip
ramips: add support for Planex CS-QR10
CS-QR10 is MT7620A based IP Camera. the camera and sound does not work with kernel 4.4. - camera chip is sn9c291. - sound chip is wm8960. Signed-off-by: YuheiOKAWA <tochiro.srchack@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49234 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/mt7620/profiles/planex.mk')
-rw-r--r--target/linux/ramips/mt7620/profiles/planex.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/planex.mk b/target/linux/ramips/mt7620/profiles/planex.mk
index f6f2cf187c..15560ab50d 100644
--- a/target/linux/ramips/mt7620/profiles/planex.mk
+++ b/target/linux/ramips/mt7620/profiles/planex.mk
@@ -5,6 +5,20 @@
# See /LICENSE for more information.
#
+define Profile/CS-QR10
+ NAME:=Planex CS-QR10
+ PACKAGES:=\
+ kmod-usb-core kmod-usb2 kmod-usb-ohci \
+ i2c-core kmod-i2c-ralink kmod-sound-core kmod-sound-mtk \
+ kmod-sdhci-mt7620
+endef
+
+define Profile/CS-QR10/Description
+ Package set optimized for the Planex CS-QR10.
+endef
+$(eval $(call Profile,CS-QR10))
+
+
define Profile/MZK-750DHP
NAME:=Planex MZK-750DHP
PACKAGES:= kmod-mt76 kmod-mt7610e