aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-04-25 19:03:01 +0000
committerJohn Crispin <blogic@openwrt.org>2013-04-25 19:03:01 +0000
commitecff443b65c881f93dee8ef643b70881535e88f2 (patch)
treee34d1665badfb0f41b2dfba58f7aecae60e0312c /target/linux/ramips/image
parente5adedfdd5b5381097ec8a22f14616749dfe8f70 (diff)
downloadmaster-187ad058-ecff443b65c881f93dee8ef643b70881535e88f2.tar.gz
master-187ad058-ecff443b65c881f93dee8ef643b70881535e88f2.tar.bz2
master-187ad058-ecff443b65c881f93dee8ef643b70881535e88f2.zip
ramips: introduce DTS for ALL5003
Prior to the switch to 3.8, ALL5002 and ALL5003 boards shared mach-all5002.c. With the change to DTS, this is no longer accurate, as ALL5002 is based on Rt3352 SoC while ALL5003 is based on Rt5350 SoC, therefore the corresponding rt5350.dtsi need to be included for ALL5003. Signed-off-by: Daniel Golle <dgolle@allnet.de> Patchwork: http://patchwork.openwrt.org/patch/3557/ Acked-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36435 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 99d4702403..621f23edb9 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -265,6 +265,7 @@ Image/Build/Profile/ALL0256N=$(call BuildFirmware/DefaultDualSize/$(1),$(1),all0
allnet_all5002_mtd_size=33226752
Image/Build/Profile/ALL5002=$(call BuildFirmware/CustomFlash/$(1),$(1),all5002,ALL5002,$(allnet_all5002_mtd_size))
+Image/Build/Profile/ALL5003=$(call BuildFirmware/CustomFlash/$(1),$(1),all5003,ALL5003,$(allnet_all5002_mtd_size))
argus_atp52b_mtd_size=7995392
Image/Build/Profile/ARGUS_ATP52B=$(call BuildFirmware/CustomFlash/$(1),$(1),argus_atp52b,ARGUS_ATP52B,$(argus_atp52b_mtd_size))
@@ -436,6 +437,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/ALL02393G,$(1))
$(call Image/Build/Profile/ALL0256N,$(1))
$(call Image/Build/Profile/ALL5002,$(1))
+ $(call Image/Build/Profile/ALL5003,$(1))
$(call Image/Build/Profile/ARGUS_ATP52B,$(1))
$(call Image/Build/Profile/ASL26555,$(1))
$(call Image/Build/Profile/BC2,$(1))