aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-08-01 20:51:24 +0000
committerJohn Crispin <blogic@openwrt.org>2014-08-01 20:51:24 +0000
commita3ea08a8254c2d653bd9440441e59a9bfdc1394b (patch)
treebaaade8dd30a3574b4e0da69219f583c8b0e244d /target/linux/ramips/image
parentc6ded2d17c8dee15a119191b3ca2e3efd924521f (diff)
downloadmaster-187ad058-a3ea08a8254c2d653bd9440441e59a9bfdc1394b.tar.gz
master-187ad058-a3ea08a8254c2d653bd9440441e59a9bfdc1394b.tar.bz2
master-187ad058-a3ea08a8254c2d653bd9440441e59a9bfdc1394b.zip
ramips: Add support for VoCore
This is based and tested on VoCore Alpha, but other stuff like status/eth LEDs are present on the final board revision + VoDock. All GPIOs are exported, except spi/i2c. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41939 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index c8f1a433d9..6dfaee5d81 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -473,6 +473,8 @@ Image/Build/Profile/SL-R7205=$(call BuildFirmware/Default4M/$(1),$(1),sl-r7205,S
Image/Build/Profile/V22RW-2X2=$(call BuildFirmware/Default4M/$(1),$(1),v22rw-2x2,V22RW-2X2)
+Image/Build/Profile/VOCORE=$(call BuildFirmware/Default8M/$(1),$(1),vocore,VOCORE)
+
Image/Build/Profile/W150M=$(call BuildFirmware/CustomFlashFactory/$(1),$(1),w150m,W150M,$(ralink_default_fw_size_4M),W150M Kernel Image,factory)
Image/Build/Profile/W306R_V20=$(call BuildFirmware/CustomFlashFactory/$(1),$(1),w306r-v20,W306R_V20,$(ralink_default_fw_size_4M),linkn Kernel Image,factory)
@@ -614,6 +616,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/SL-R7205,$(1))
$(call Image/Build/Profile/UR-326N4G,$(1))
$(call Image/Build/Profile/V22RW-2X2,$(1))
+ $(call Image/Build/Profile/VOCORE,$(1))
$(call Image/Build/Profile/W150M,$(1))
$(call Image/Build/Profile/W306R_V20,$(1))
$(call Image/Build/Profile/W502U,$(1))