aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-04-22 08:08:51 +0000
committerJohn Crispin <blogic@openwrt.org>2014-04-22 08:08:51 +0000
commit522d86d5bbae0b5f1d0fd9ea48607523a3aa6fd9 (patch)
treedaa65e41f5a91ff32df353aa2b208329351a882d /target/linux/ramips/image
parentd5e2e74b3e8437d9f15e13c2fc5c8fd3a1bf98dd (diff)
downloadmaster-187ad058-522d86d5bbae0b5f1d0fd9ea48607523a3aa6fd9.tar.gz
master-187ad058-522d86d5bbae0b5f1d0fd9ea48607523a3aa6fd9.tar.bz2
master-187ad058-522d86d5bbae0b5f1d0fd9ea48607523a3aa6fd9.zip
ramips: Add support for the 7Links PX-4885 wireless router.
The 7Links PX-4885 is a small battery-powered wireless router. It is based on a RT5350F WiSoC and features one ethernet port and one USB port. It is a Hame MPR-A1 clone, except it has different GPIOs, a different battery and more RAM (32 MB). This patch adds a profile for this board, the corresponding device tree file and the adequate base-files changes (incl. sysupgrade). Signed-off-by: Hugo Grostabussiat <bonstra@bonstra.fr.eu.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40554 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 26386bf05c..19932f6fe1 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -448,6 +448,8 @@ Image/Build/Profile/PSR-680W=$(call BuildFirmware/Default4M/$(1),$(1),psr-680w,P
Image/Build/Profile/PWH2004=$(call BuildFirmware/Default8M/$(1),$(1),pwh2004,PWH2004)
+Image/Build/Profile/PX4885=$(call BuildFirmware/Default4M/$(1),$(1),px4885,PX4885)
+
Image/Build/Profile/RTG32B1=$(call BuildFirmware/Default4M/$(1),$(1),rt-g32-b1,RT-G32-B1)
Image/Build/Profile/RTN10PLUS=$(call BuildFirmware/Default4M/$(1),$(1),rt-n10-plus,RT-N10-PLUS)
@@ -585,6 +587,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/OMNI-EMB,$(1))
$(call Image/Build/Profile/PSR-680W,$(1))
$(call Image/Build/Profile/PWH2004,$(1))
+ $(call Image/Build/Profile/PX4885,$(1))
$(call Image/Build/Profile/RTG32B1,$(1))
$(call Image/Build/Profile/RTN10PLUS,$(1))
$(call Image/Build/Profile/RT-N13U,$(1))