aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-30 20:20:08 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-30 20:20:08 +0000
commit5c7193d17b8444ca2c42ddea87b3707e035376f2 (patch)
tree732391b371efd6179179f408afe06b5064203e6f /target/linux/ramips/image/Makefile
parent0d349dc5fe18ae68ee4a5e59373eb788b3f482e1 (diff)
downloadmaster-187ad058-5c7193d17b8444ca2c42ddea87b3707e035376f2.tar.gz
master-187ad058-5c7193d17b8444ca2c42ddea87b3707e035376f2.tar.bz2
master-187ad058-5c7193d17b8444ca2c42ddea87b3707e035376f2.zip
ramips: move relocating loader to common location
Allow other targets to use it, too. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45162 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 45ae3a585a..14f6f1ef7e 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -981,7 +981,7 @@ endif
ifeq ($(SUBTARGET),mt7621)
define Build/Compile
rm -rf $(KDIR)/relocate
- $(CP) ./relocate $(KDIR)
+ $(CP) ../../generic/image/relocate $(KDIR)
$(MAKE) -C $(KDIR)/relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
endef
endif